Bug 467770 - RHN Satellite - unable to unselect Package Profile in the Kickstart profile
RHN Satellite - unable to unselect Package Profile in the Kickstart profile
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Jeff Ortel
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-10-20 16:02 EDT by Jeff Ortel
Modified: 2009-09-17 03:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Ortel 2008-10-20 16:02:34 EDT
Clone of bug: 383861
	
We created a RHN Kickstart profile and then decided to picked an existing
Package Profile as part of its configuration.  However, there is no way of
unselecting the Package Profile once it has been selected whenever the customer
changes its mind of using any Package Profile. By default there's no option
selected but no going back once a Package Profile is picked since the Web UI
uses radio buttons.

How reproducible:

Always.

Steps to Reproduce:

1.Create a Package Profile based on a registered system
2.Create a kickstart profile
3.Go to Software
4.Choose "Package Profile"
5.Pick a Package Profile
6.Click Update
7.Try to unselect the Package Profile

Actual results:

No way to unselect package profiles and not use any package profiles at all.

Expected results:

Able to change mind in using or not using package profiles in kickstart

Had to recreate the entire kickstart profile and not pick any package profile to
achieve what we want

Additional info:

Probably having another radio button option of "NONE" or a button of "Unselect
all" to be able to change mind in using a package profile 
This event sent from IssueTracker by xdmoon  [Support Engineering Group]
 issue 136186

-- Additional comment from tao@redhat.com on 2007-10-29 22:58 EST --
Verified for Hosted.


This event sent from IssueTracker by xdmoon  [Support Engineering Group]
Comment 1 Jeff Ortel 2008-10-20 16:06:12 EDT
The profile can be unselected by pressing the "Unassociate Profile" button.  Changed the order of the buttons and rename "Unassociate" to "Clear Package Profile" so that it will be clearer for users.
Comment 2 Jesus M. Rodriguez 2009-04-14 10:11:43 EDT
Spacewalk 0.5 released.
Comment 3 Miroslav Suchý 2009-09-17 03:08:32 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.