Bug 467779 - makehuman won't launch
makehuman won't launch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 16:57 EDT by ciol13
Modified: 2009-04-14 12:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 12:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ciol13 2008-10-20 16:57:37 EDT
When I launch makehuman, it crashes:

$ makehuman
makehuman: brw_vtbl.c:98: brw_new_batch: Assertion `!brw->no_batch_wrap' failed.
Abandon

However, a makehuman directory is created in $HOME.

It's the latest Fedora version, 0.9.1-0.3.rc1a.fc9

I tried to backtrace via gdb:

$ gdb makehuman
 (gdb) set pagination 0
 (gdb) run

But my hole system freezes. I had to hard reboot.
Comment 1 Nicolas Chauvet (kwizart) 2008-10-20 17:05:53 EDT
Which GPU do you have, and which driver are you using ?
If you don't have 3D capabilities for your GPU, it is not expected to work.
Comment 2 ciol13 2008-10-21 03:27:47 EDT
lspci gives me:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

How can I know if it has 3D capabilities?

Don't know if it's useful:

# glxinfo | grep rendering
direct rendering: Yes

I'm using the "intel" driver (I checked in xorg.conf).
Comment 3 Nicolas Chauvet (kwizart) 2008-10-21 03:50:18 EDT
Unfortunately, this "might" be an hardware problem.
Despite intel produces good open source drivers, which allow compiz and others 3D games to be played, the graphic card isn't capable of running OpenGL softwares.
But indeed, it could be possible to exit more gracefully.

Closing to CANTFIX, but you could have a try on next intel drivers version.
(for now I'm using makehuman with radeon open source drivers on a latptop with a x600se card.)
Comment 4 Nicolas Chauvet (kwizart) 2008-10-21 03:52:30 EDT
By "running OpenGL software", I meant: such softwares with hight OpenGL needs (blender, makehuman, etc).
Comment 5 ciol13 2008-10-21 04:07:01 EDT
Thanks. I chose Intel because I thought everything worked with free drivers.

> you could have a try on next intel drivers version.

The best solution is to wait for a new xorg version and so Fedora 10?


By the way the exact name of my GPU is "Intel GMA X3100".
Comment 6 Nicolas Chauvet (kwizart) 2008-10-21 04:28:16 EDT
(In reply to comment #5)
> Thanks. I chose Intel because I thought everything worked with free drivers.
Yes, but it depends on what are your needs. Others GPU are more expensive for good reasons. As that's the same for CPU.
> > you could have a try on next intel drivers version.
> 
> The best solution is to wait for a new xorg version and so Fedora 10?
There is probably nothing to do. You will never be able to run makehuman on such cheap GPU.
Comment 7 Nicolas Chauvet (kwizart) 2008-10-21 04:32:04 EDT
I will try to request on the list for advices, to see if someone get makehuman to work with an intel GPU.
Comment 8 ciol13 2008-10-21 04:38:59 EDT
Well, I randomly searched on the Internet (I understand nothing in 3D, xorg, drivers etc.), I added:
Option "DRI" "off"
In the Device section of xorg.conf, and makehuman seems to work.
I guess it will be slow.
What it's strange is that I still have :

$ glxinfo | grep rendering
direct rendering: Yes
Comment 9 Nicolas Chauvet (kwizart) 2008-10-21 05:20:10 EDT
Well, I'm sorry. I've made a wrong assumption then.
Re-assigned to the intel xorg driver.
Comment 10 Nicolas Chauvet (kwizart) 2008-10-21 05:26:45 EDT
It would worth to give a try on rawhide:
http://torrent.fedoraproject.org/
The better would be to use a LiveUSB (either usb key or hard disk), to transfert the iso to the device using livecd-iso-to-disk --overlay-size-mb 512
and then to install makehuman on the liveUSB (using the overlay).
Comment 11 Benjamin Thery 2008-11-27 07:40:53 EST
Nicolas, 

Your assumption that "the [Intel] graphic card isn't capable of running [these] OpenGL softwares." is completely wrong. I've used Blender and Makehuman a lot with 3D-acceleration on Intel chipsets on several previous Fedora releases.
Both apps always worked great, until Fedora 10. 

There seem to have a lot of problems (many bugs opened) with the latest Intel graphic drivers and Fedora 10.
Comment 12 Nicolas Chauvet (kwizart) 2009-01-22 09:42:53 EST
@Benjamin
Does the problem still appears currently ?
Comment 13 Benjamin Thery 2009-01-22 10:50:47 EST
Blender still have problems with current F10 and OpenGL acceleration with my Intel chipset (Bug #479153).

But I don't know about Makehuman and the specific problem reported in this bug. Haven't ran Makehuman in a while. I will try to find some time to test it.
Comment 14 Benjamin Thery 2009-01-22 10:57:50 EST
I've just installed the latest package available (makehuman.i386 0:0.9.1-0.3.rc1a.fc9).

It seems to work. It doesn't crash at startup.
It's quite slow but it works.
Comment 15 Nicolas Chauvet (kwizart) 2009-04-14 12:00:45 EDT
According that the package currently works... this bug should be closed.
Closing to currentrelease, please re-open if there is a case where it doesn't works.

Note You need to log in before you can comment on or make changes to this bug.