Bug 467792 - Cannot login as root user
Cannot login as root user
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-20 17:44 EDT by Cliff Schomburg
Modified: 2015-01-14 18:21 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-01 08:19:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Cliff Schomburg 2008-10-20 17:44:55 EDT
Description of problem:
System will not allow me to login as root user.  However, I can "login" in the terminal using the 'su' command and I can use the root password to authenticate as root in the GUI.

Version-Release number of selected component (if applicable):
F10 Beta (9.91)

How reproducible:
Attempt to login at runlevel 5 (NOTE: I have not attempted logins at lower runlevels, so I am not sure if they would work)

Steps to Reproduce:
1. At login screen, click "Other"
2. Enter username as "root" and root password
3. System will return an error saying "Cannot authenticate user"
Actual results:
Cannot login as root with correct password

Expected results:
Should be able to login as root with correct password

Additional info:
Comment 1 electronrancher 2008-11-12 13:04:18 EST
Behavior is same in F10, 9.92 as well.
Comment 2 Bug Zapper 2008-11-25 23:02:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 3 Richard Schwarting 2008-12-07 22:11:09 EST
This behaviour is controlled in /etc/pam.d/gdm, I think.  I suppose it is deliberately set.  You can remove the following restriction, if you like:
"#auth       required    pam_succeed_if.so user != root quiet"

I suppose this is supposed to be a bad idea.
Comment 4 depanker 2008-12-25 09:58:00 EST
In addition to root being restricted to login there is also a restriction on, if user manages to login as root he cannot use graphical application.
In Fedora Core 8 there was just a warning, but in Fedora 10 User is not even given a choice.
Guy's Fedora is such an awesome product but the fact that user is being restricted in this manner should be avoided, even if it is not advisable to login as root, a warning should be given, but it should still be users choice as to follow those warnings or not.
Comment 5 stephen brede 2009-03-13 04:18:37 EDT
First time install of FC10 on a spare partition of an XP i86-64 machine.
Gave acceptable root password (all numbers)and when install restarted PC could not find FC10 partition (resolved with grub4dos for now).
Finally booted FC10 and it asked for a user which I gave OK.
Went to mount ntfs partitions and locate network printer which both required root password.
Password not authenticated.
Used aplawrence.com/linux method of getting into FC10 single user and reset root password successfully (I thought) although FC10 said it was dictionary based it appeared to accept it and restarted.
Again tried to setup network printer and ntfs drives and root password not authenticated.
Ran updater in vain hope a fix had already been done for this but still no soap.
confused as to why this happened at all let alone why it hasn't been fixed.
Comment 6 Richard Schwarting 2009-03-13 04:45:21 EDT
Stephen, I think you're having a different problem.  

The issue described here is that Fedora prevents users from logging into the system as the root user from the main login screen.  Users should probably not run a desktop as the root user, and if they really want to, then they should know how to make the relevant change (noted above) to let them log into the system like that.

Regular users should still be able to authenticate as the root user within their own session.  Specific problems relating to mounting an NTFS partition or locating a network printer are probably unrelated.  On that note, I don't seem to require root to mount an NTFS partition: it appears on the desktop whenever one is connected and I'm logged in (as my regular user).  

I hope I'm not missing something.  Also, if you think there is a problem with authenticating as root for those tasks, please create a new bug specific for that.  Cheers!
Comment 7 Adam Pribyl 2009-07-01 08:19:53 EDT
I'm closing this bug as NotABug. This is on purpose and admin can enable the root login. If there are any other issues, please reopen. Problem described by stepehen is not related to gdm.

Note You need to log in before you can comment on or make changes to this bug.