Bug 467797 - When in Run Level 3 (likely all text mode run levels), not possible to enter quotes, other non-alphabetic characters
When in Run Level 3 (likely all text mode run levels), not possible to enter ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 18:00 EDT by Peter Gückel
Modified: 2008-12-02 05:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 05:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2008-10-20 18:00:32 EDT
Description of problem:
Log into run level 3. Type " or ' or presumably a few other symbolic characters and nothing happens - they do not get typed.

Version-Release number of selected component (if applicable):
1.12-31.fc9 (although I am using Rawhide 9.92 - quasi F10)

How reproducible:
Type " or '

Steps to Reproduce:
1. Type " or '
2. Notice that nothing appears on the input line
3.
  
Actual results:
Keys are dead

Expected results:
The key that is depressed should be typed.

Additional info:
I have /etc/sysconfig/keyboard set to: KEYBOARDTYPE="pc" and KEYTABLE="us-acentos". This produces the desired and expected results in X, namely, that the diacritical marks are dead until the accented character is typed; or typing the diacritical mark twice in succession types the diacritical mark, etc. Also, the key that is shown on the key itself is the one that is typed. On the command line, however, some keys don't type anything (quotes and apostrophes are essential for bash commands, for example, which are often typed on a command line; the foreign language diacritical marks are less critical for the command line, but properly, they, too, should work both in X and on the command line).
Comment 1 Bug Zapper 2008-11-25 23:03:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Vitezslav Crhonek 2008-12-01 11:04:48 EST
Hi,

I'm not able to reproduce it on Fedora 10.

At first, I believe that /etc/sysconfig/keyboard sets keytable for console only. X setup is different and it's not part of kbd package.

Using identical /etc/sysconfig/keyboard setup as you have, I was able to type accented characters (press quote and then desired character to be accented) and also quotes and apostrophes (press quote or apostrophe and then spacebar) in console. Runlevel doesn't matter, you should switch to console in Runlevel 5 (e.g. with ctrl+alt+F2) and result is the same as in Runlevel 3.
Comment 3 Peter Gückel 2008-12-01 12:46:04 EST
I am on f10 now, too.

I tried what you said, i.e., ctrl-alt-f2, and I was able to get the diacritical marks to print, albeit not the way they work while in the graphical mode.

Normally, one types the key followed by the letter one wishes to accent, or alt-thekey to get it to print itself, while on the command line, I just learned from your previous post, one types thekey followed by space. This verily works, albeit not in the standard way.
Comment 4 Vitezslav Crhonek 2008-12-02 05:53:44 EST
I suppose you use "USA International (with dead keys)" in X - it works like you described.

I acknowledge that console keymap works a bit differently, but that's not a bug. (It also produces different characters sometimes - e.g. try sequence "'c" in X and console). Console and X are just different worlds...

Also note, that it will be not good idea to change behaviour of this keymap (/lib/kbd/keymaps/i386/qwerty/us-acentos.map.gz), because I can imagine confuse of users that are familiar with this for years (at least kbd in Fedora 6 works the same way, I have no machine with older version around). So closing WONTFIX.

But if you like to have same (or more similar) keymap in console as you use in X, you can modify current console keymap and create new one based on it. If there is wider set of people interested in, I believe that upstream will accept it as a regular part of kbd package.

Note You need to log in before you can comment on or make changes to this bug.