Bug 467821 - assorted fail with radeon xpress 200m
assorted fail with radeon xpress 200m
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
NEEDSRETESTING
: Reopened, Triaged
Depends On:
Blocks: nomodeset
  Show dependency treegraph
 
Reported: 2008-10-20 22:57 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:37:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log (73.76 KB, text/plain)
2008-10-20 22:57 EDT, Dave Jones
no flags Details
X Log (77.16 KB, text/plain)
2008-11-21 16:16 EST, Alex Launi
no flags Details
Xorg.0.log after crash (80.52 KB, text/plain)
2008-11-29 05:11 EST, Dino Sangoi
no flags Details
full boot log extracted from /var/log/messages.txt (733.66 KB, text/plain)
2008-11-29 05:16 EST, Dino Sangoi
no flags Details
Xorg.0.log showing lockup of ATI 200m card (157.73 KB, text/x-log)
2008-11-30 11:09 EST, westbrook
no flags Details

  None (edit)
Description Dave Jones 2008-10-20 22:57:46 EDT
Created attachment 320959 [details]
X log

after a few minutes, X locks up.
I can ssh in, but gdb on the process doesn't tell me much..

(gdb) bt
#0  0x00007fc6ccdd5123 in select () from /lib64/libc.so.6
#1  0x00000000004e4bfb in WaitForSomething ()
#2  0x000000000044661f in Dispatch ()
#3  0x000000000042ccdd in main ()

some scary looking info in dmesg ..

mtrr: base(0xc950c000) is not aligned on a size(0x7e9000) boundary
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id

X log attached.
Comment 1 Dave Jones 2008-10-20 23:26:27 EDT
iirc we didn't enable DRI on this chip in F9, whereas now it's enabled by default. On a hunch, I generated a config file with X -configure, and commented out the Load "dri" and added an Option "DRI" "no"

When I restart X, the log contains..

(II) Loading extension XFree86-DRI
(**) RADEON(0): Option "DRI" "no"
(II) RADEON(0): [DRI] installation complete
(II) GLX: Initialized DRI GL provider for screen 0

so it seems to ignore everything I told it to.


additional fail: Once X has started, I can't get to the terminals on ttys1-6 any more. ctrl-alt-whatever still shows the last thing that X displayed.
Comment 2 Jesse Keating 2008-10-27 18:43:16 EDT
this doesn't seem to be an overly popular card, at least not from the mailing list traffic and bugzilla traffic.  I don't believe I'd slip Preview for this bug, maybe not even final release.  I'm moving over to F10Target.
Comment 3 Chuck Ebbert 2008-10-31 03:07:01 EDT
This adapter is the integrated video on a very large number of notebooks with the ATI RS4XX integrated chipset.
Comment 4 Will Woods 2008-11-13 18:29:34 EST
airlied mentioned something about blacklisting or otherwise fixing up this card; moving back to Blocker to ensure we get whatever we needed there.
Comment 5 Orion Poplawski 2008-11-14 11:42:53 EST
*** Bug 471498 has been marked as a duplicate of this bug. ***
Comment 6 Orion Poplawski 2008-11-14 11:47:43 EST
Is there any work around for this?
Comment 7 Bill Nottingham 2008-11-17 13:35:53 EST
Does installing the kernel available at http://kojipkgs.fedoraproject.org/packages/kernel/2.6.27.5/113.fc10/ help at all?
Comment 8 Dave Jones 2008-11-17 13:43:44 EST
I loaned the failing laptop to ajax, so I can't test it right now.
Comment 9 Thomas Canniot 2008-11-17 16:12:07 EST
(In reply to comment #7)
> Does installing the kernel available at
> http://kojipkgs.fedoraproject.org/packages/kernel/2.6.27.5/113.fc10/ help at
> all?

No it doesn't. Not better, not worse.
Comment 10 Dave Airlie 2008-11-17 16:24:25 EST
so the symptoms are the same X lockups after a few minutes?

can you please try the latest xorg-x11-server from koji

1.5.3-5

to see it it helps.
Comment 11 Jesse Keating 2008-11-18 17:47:01 EST
Setting to modified as we think it's fixed in the latest Xorg server.
Comment 12 Jesse Keating 2008-11-18 22:33:19 EST
Actually closing.  Please re-open if you have this exact bug, or file a new one if you have a different bug.
Comment 13 Alex Launi 2008-11-21 16:15:11 EST
I still experience this bug on Fedora F10 preview, fully updated. I've got an RS480 chipset, x200m. Attching my xorg.log.0

System Info:
Linux picard 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 athlon i386 GNU/Linux
xorg-x11-server-Xorg-1.5.3-5.fc10.i386
Comment 14 Alex Launi 2008-11-21 16:16:17 EST
Created attachment 324347 [details]
X Log
Comment 15 Will Woods 2008-11-21 16:45:31 EST
This still affects *some* xpress 200m chips, but 'nomodeset' seems to be a viable workaround.
Comment 16 Dave Airlie 2008-11-23 04:06:13 EST
Can someone try Option "EXANoComposite" "true" in xorg.conf

This might be a bit slow but I just want to narrow down where the hang is coming into play.
Comment 17 Dave Airlie 2008-11-23 22:59:19 EST
I've just kicked off a new kernel build in koji.

kernel-2.6.27.5-123.fc10

it'll appear here when finished.

http://kojipkgs.fedoraproject.org/packages/kernel/2.6.27.5/123.fc10/

Can some rs480 users install it and see if it helps with these issues?

with modesetting running of course.
Comment 18 Dave Airlie 2008-11-25 01:34:15 EST
Also if you can try 

xorg-x11-drv-ati-6.9.0-57 on top of that kernel and see does it help any that would be great.
Comment 19 Bug Zapper 2008-11-25 23:04:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 shaun oleson 2008-11-26 22:16:33 EST
Hey guys - I'm pretty much a newb, but i'm running into the same issues. The nomodeset kernel opt will allow me to boot. The issue started after installing the proprietary ATI drivers (8.11).

lspci shows:
VGA Compatible Controller: ATI Technologies Inc RS485 [Radeon Express 1100 IGP]

I was able to install the above kernel-devel and kernel-headers but kernel failed with a dep required (kernel-firmware >= 2.6.27.5-123)

I wasn't able to get my hands on that pkg to test the kernel. Also, I wasn't able to locate the xorg ati driver (build 57). The latest I have is 6.9.0-54.

I'm more than happy to help the cause here, but again, it's a learning process. Let me know if you need any further info.
Comment 21 Wade Hampton 2008-11-28 22:41:05 EST
Gateway MX6421 laptop with Radeon Express 200M locks up on a regular basis with Fedora 10 (latest updates applied). The keyboard and mouse are non-responsive and I have not tried SSHing into the box.  If you have any options to try or a beta driver, e-mail me and I'll try to test it.  If dmesg or xorg logs are desired, please send me an e-mail.

Note that this system has been up nearly continuously with Fedora 6 for several years with very good results.  I finally decided to reload it with F10 and have spent most of the afternoon trying to get it to work....  The non-free drivers won't load either.

As I need this machine I will either have to use XP on it (dual boot), or downgrade to Fedora 9.  (Also note that the CD-ROM died so I have to do an install using the kernel and initrd copied to the hard disk - PITA.)
Comment 22 Dino Sangoi 2008-11-29 05:07:30 EST
Just another data point:

I have an HP  nx6125 laptop, with an ATI Xpress 200M card. Hardware info at:
http://www.smolts.org/client/show/pub_12bb8d72-171e-4c11-9e8c-eeff3ce3682b, lspci in bug #240343.

On my system, using modeset (the default), X hangs after a bit (usually a 'find /' run on a gnome-terminal makes the system hang after few seconds).

The system seems to work (e.g. I can do Alt-SysRQ commands). I have not tried to login via ssh.

The hang doesn't happen using 'nomodeset' kernel option, OR reverting to xorg-x11-drv-ati-6.9.0-38.fc10.i386.

Changing the kernel doesn't seems to make any difference, I have tried -117 (from repo), -123 and -130 (both from koji).

Adding 'option "EXANoCompositing" "true"' also makes the system stable, but the 'find /' command runs so slow that maybe ad this speed the problem simply doesn't trigger.

I will attach the Xorg.0.conf after a crash, the messages.txt log after pressing Alt-SysRQ with 'W', 'P', 'Q' 'D'. All this with -123 kernel and -54 ati driver.

(I have also the logs using nomodeset, with EXANoCompositing, and other combinations, but those seems to me less useful, I you need those just ask)
Comment 23 Dino Sangoi 2008-11-29 05:11:06 EST
Created attachment 325075 [details]
Xorg.0.log after crash

It contains a backtrace and some errors near the end.
Comment 24 Dino Sangoi 2008-11-29 05:16:27 EST
Created attachment 325076 [details]
full boot log extracted from /var/log/messages.txt

This contains the info relevant to the boot that end in a X hang. At the end there is the output of Alt-SysRQ Q, W, P, D (and maybe something else I don't remember right now).
As you an guess, the system is alive enough to handle the sysrq commands, run syslog and write the output to the log file.
Comment 25 westbrook 2008-11-30 11:09:04 EST
I have the exact same problem going on with my HP 5120us laptop I just upgraded from a very stable Fedora 9 i386 install.  I also did a clean install of x86_64 and it's doing the same exact thing.  AFter a few minutes, X locks up cold.  

Here is some info from /var/log/messages:
Nov 30 08:28:24 westlap kernel: allocated ffff8800378e8000 1280x800 fb: 0x00040000, bo ffff88007d
6d6080
Nov 30 08:28:24 westlap kernel: Console: switching to colour frame buffer device 160x50
Nov 30 08:28:24 westlap kernel: [drm] LVDS-8: set mode  a
Nov 30 08:28:24 westlap kernel: [drm] bios LVDS_GEN_CNTL: 0x30ff20
Nov 30 08:28:24 westlap kernel: fb0: radeondrmfb frame buffer device
Nov 30 08:28:24 westlap kernel: registered panic notifier
Nov 30 08:28:24 westlap kernel: [drm] Loading R300 Microcode
Nov 30 08:28:24 westlap kernel: [drm] Num pipes: 2
Nov 30 08:28:24 westlap kernel: [drm] writeback test succeeded in 1 usecs
Nov 30 08:28:24 westlap kernel: [drm] Initialized radeon 1.29.0 20080528 on minor 0

I've attached my Xorg.0.log
Comment 26 westbrook 2008-11-30 11:09:48 EST
Created attachment 325132 [details]
Xorg.0.log showing lockup of ATI 200m card
Comment 27 Dino Sangoi 2008-11-30 11:24:30 EST
I have just tried kernel-2.6.27.7-132.fc10.i686 from koji, using xorg-x11-drv-ati-6.9.0-54.fc10.i386 (the "current" release from "fedora" repo), and a "find /" inside a gnome-terminal still hangs X.

I can report dmesg, Xorg.log and other info if needed.
Comment 28 Wade Hampton 2008-12-01 09:17:15 EST
As recommended, I tried the nomodeset kernel option and the laptop is now usable
(add nomodeset to the kernel line in /etc/grub.conf).

The laptop is still setup for runlevel 3 and I have to use startx to start X windows but it works.  However, when I tried to logout of X, the laptop hung so
all is not fixed.
Comment 29 Bug Zapper 2009-11-18 03:36:49 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Bug Zapper 2009-12-18 01:37:03 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.