Bug 467822 - two grub entries get written
two grub entries get written
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 479072 (view as bug list)
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-10-20 23:28 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 03:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (55.80 KB, text/plain)
2008-10-21 13:14 EDT, Dave Jones
no flags Details
install.log (43.55 KB, text/plain)
2008-10-21 13:15 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2008-10-20 23:28:46 EDT
this has been bugging me for months, but no-one seems to have fixed it, so I figure it's worth reporting.

After install, there are two grub entries.
"Fedora" and "Fedora-base".  Both of which are identical.
Comment 1 Jeremy Katz 2008-10-21 09:07:44 EDT
What type of install is this with?  And can you attach 'rpm -q --whatprovides kernel', /root/install.log and /var/log/anaconda.log?
Comment 2 Dave Jones 2008-10-21 13:13:15 EDT
install was pxe & nfs.

This is disturbing ...

$ rpm -q --whatprovides kernel
kernel-2.6.27.3-27.rc1.fc10.x86_64
kernel-2.6.27.3-27.rc1.fc10.x86_64

logs to follow..
Comment 3 Dave Jones 2008-10-21 13:14:14 EDT
Created attachment 321044 [details]
anaconda log
Comment 4 Dave Jones 2008-10-21 13:15:10 EDT
Created attachment 321047 [details]
install.log
Comment 5 Jeremy Katz 2008-10-21 13:23:50 EDT
That is interesting and not what I'd expect.  Panu -- any thoughts on what would be causing multiple entries in the rpmdb?
Comment 6 Panu Matilainen 2008-10-22 01:42:22 EDT
From the above install.log it seems to be installed twice, which sorta explains:
[pmatilai@localhost ~]$ grep kernel-2 /tmp/install.log 
Installing kernel-2.6.27.3-27.rc1.fc10.x86_64
Installing kernel-2.6.27.3-27.rc1.fc10.x86_64

It gets added to the transaction twice, but that rpm doesn't filter it out the duplicate is of course an rpm bug. Easily reproduced on command line too, this only happens for "pure" install, not upgrade:

[root@localhost x86_64]# rpm -Uvh test-2-1.x86_64.rpm test-2-1.x86_64.rpm 
warning: package test = 2-1 was already added, skipping test < 2-1
Preparing...                ########################################### [100%]
   1:test                   ########################################### [100%]
[root@localhost x86_64]# rpm -e test
[root@localhost x86_64]# rpm -ivh test-2-1.x86_64.rpm test-2-1.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:test                   ########################################### [ 50%]
   2:test                   ########################################### [100%]
[root@localhost x86_64]#

Oops :) Seems to happen on both 4.4.2.x and 4.6.x... will fix.
Comment 7 Panu Matilainen 2008-10-22 03:22:57 EDT
Fixed in rawhide now (rpm-4.6.0-0.rc1.3)

Anaconda adding the same package twice to transaction is kinda wrong anyway, but rpm now handles this corretly (warns and skips).
Comment 8 Alan Conway 2009-01-07 17:34:33 EST
*** Bug 479072 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.