Bug 467838 - (CVE-2008-6079) CVE-2008-6079 imlib2: New upstream release 1.4.2 contains security updates
CVE-2008-6079 imlib2: New upstream release 1.4.2 contains security updates
Status: CLOSED RAWHIDE
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
http://sourceforge.net/project/showno...
public=20081021,reported=20090206,imp...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 03:44 EDT by Hans de Goede
Modified: 2009-02-06 08:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 02:18:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-10-21 03:44:18 EDT
As the previous maintainer of imlib2 I'm subscribed to imlib2 releases (through the subscribe to new release feature of sourceforge).

As such I was attented to a new imlib2 release done today: 1.4.2:
http://sourceforge.net/project/showfiles.php?group_id=2&release_id=634778

I will unsubscribe from those releases now, I can advise you to subscribe :)
Comment 1 Tomas Smetana 2008-10-21 03:57:16 EDT
(In reply to comment #0)
> As the previous maintainer of imlib2 I'm subscribed to imlib2 releases (through
> the subscribe to new release feature of sourceforge).
> 
> As such I was attented to a new imlib2 release done today: 1.4.2:
> http://sourceforge.net/project/showfiles.php?group_id=2&release_id=634778
> 
> I will unsubscribe from those releases now, I can advise you to subscribe :)

Thank you. I've already subscribed. I will probably wait for the new devel (F-11) branch because I think too late to rebase imlib2 in F-10.
Comment 2 Hans de Goede 2008-10-21 04:09:45 EDT
(In reply to comment #1)
> Thank you. I've already subscribed. I will probably wait for the new devel
> (F-11) branch because I think too late to rebase imlib2 in F-10.

Nope, better update now and also put updates in updates-testing for F-9 and F-8, quoting the (very verbose) release notes:
"Notes: Various bugfixes and security updates"

Note the *security updates*, also this is a minor release, so chances for regressions should be low.
Comment 3 Tomas Smetana 2008-10-21 04:17:16 EDT
OK. Will do. Thanks again.
Comment 4 Fedora Update System 2008-10-23 04:45:30 EDT
imlib2-1.4.2-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/imlib2-1.4.2-1.fc9
Comment 5 Fedora Update System 2008-10-23 05:12:39 EDT
imlib2-1.4.2-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/imlib2-1.4.2-1.fc8
Comment 6 Fedora Update System 2008-10-24 19:49:04 EDT
imlib2-1.4.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update imlib2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-9120
Comment 7 Fedora Update System 2008-10-24 19:52:57 EDT
imlib2-1.4.2-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update imlib2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9174
Comment 8 Fedora Update System 2008-11-11 21:55:08 EST
imlib2-1.4.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-11-11 22:00:07 EST
imlib2-1.4.2-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Jan Lieskovsky 2009-02-06 08:44:47 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-6079 to
the following vulnerability:

Multiple unspecified vulnerabilities in imlib2 before 1.4.2 have
unknown impact and attack vectors.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-6079
http://sourceforge.net/project/shownotes.php?release_id=634778
http://www.securityfocus.com/bid/31880
http://www.frsirt.com/english/advisories/2008/2898
http://secunia.com/advisories/32354

Note You need to log in before you can comment on or make changes to this bug.