Bug 46785 - dvips wysiwyg error in math mode (not in tetex-1.0.6)
dvips wysiwyg error in math mode (not in tetex-1.0.6)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: tetex (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-30 09:49 EDT by jhs28
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 06:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LaTeX file to recreate the bug (also contains additional details) (7.69 KB, patch)
2001-06-30 09:51 EDT, jhs28
no flags Details | Diff
a diff of my (hacked) spec file which allows the package to be built without Japanese support so that the errors are not created (3.73 KB, patch)
2001-06-30 09:53 EDT, jhs28
no flags Details | Diff

  None (edit)
Description jhs28 2001-06-30 09:49:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19-6.2.1smp i686; en-US;
rv:0.9.1) Gecko/20010607

Description of problem:
The math mode sub- and super-script spacing such as that in
$\delta_\mathrm{io}$ and $27^{\circ}$ is incorrectly rendered to PostScript
by dvips in certain circumstances. These errors do NOT occur with
tetex-1.0.6-11, but probably occur with all tetex package relases since Feb
6 2001. 

How reproducible:
Always

Steps to Reproduce:
I will submit a sample tex file which reproduces the errors (and contains
additional detailed information on the bug). 

Reproduce the error with:
1. latex  tetex_rawhide_error.tex
2. dvips -o tetex_rawhide_error.ps tetex_rawhide_error.dvi
3. xdvi tetex_rawhide_error.dvi
4. gv tetex_rawhide_error.ps
5. lpr tetex_rawhide_error.ps (only if you have a PS printer)


Actual Results:  Look at the math mode sub- and super-script spacing in
xdvi compared with the PostScript. The PostScript versions are incorrect in
several places in the document.

Expected Results:  The dvi and PostScript versions should match EXACTLY.

Additional info:

I am using tetex-1.0.7-22 from RedHat rawhide built from SRPM on a (not
terribly customized) RedHat 6.2 machine (rpm --rebuild
tetex-1.0.7-22.src.rpm followed by an rpm -Fhv ...). The binary packages
are dependent upon a libstdc++ library to which I do not wish to upgrade. I
have good reason to believe this problem will be exhibited by the binary
packages, also (see below where I fix the problem by editing the SRPM spec
file). I have made sure to replace my teTeX configuration files (texmf.cnf
and mktex.cnf) with the .rpmnew ones generated from the package install.

I have recomplied the rawhide SRPM after editing the spec file to exclude
the ASCII Corp. dvips patches for Japanese support which was enabled in the
spec file on Feb 6 2001 for bug 26249 (details of my spec file are included
as an attachment in my bugzilla report), and the resulting dvips works
without error. Therefore, I do not think the existing packaging of teTeX
should continue to have Japanese support until these patches do not break
dvips. This is a SERIOUS ERROR which discredits the integrity of the mature
teTeX distribution and which will surely cause users to produce incorrect
PostScript output. I view such an error as serious as "loss of data", so I
feel like this bug should be classified as more than "normal" severity
(esp. since the bug is entirely due to enabling Japanese support to fix
another bug).
Comment 1 jhs28 2001-06-30 09:51:29 EDT
Created attachment 22287 [details]
LaTeX file to recreate the bug (also contains additional details)
Comment 2 jhs28 2001-06-30 09:53:43 EDT
Created attachment 22288 [details]
a diff of my (hacked) spec file which allows the package to be built without Japanese support so that the errors are not created
Comment 3 Tim Waugh 2001-07-03 10:41:58 EDT
Yes, this happens with the precompiled binary packages too.  Turning off 
Japanese support entirely is a little drastic, and 'Japanese doesn't work at 
all' is more severe than this bug.

Is the problem definitely in the dvipsk patch, I wonder?
Comment 4 jhs28 2001-07-19 13:55:44 EDT
The problem is solely due to the patch for dvips in dvipsk-jpatch-p1.5d.tar.gz.
I verified this in the tetex-1.0.7-24 SRPM by commenting out the following line
(line 292) of the spec file:

   patch -d texk -p0 < dvipsk-j/dvipsk586.patch

As packaged, tetex-1.0.7-24 has the dvips error I have described, but when this
single line is commented out, the error goes away (and luckily none of the other
patches fail!).

I can see your position in needing to have support for Kanji in your teTeX
distribution for all the Japanese RedHat users, but I'm disappointed that yet
again a large software vendor is choosing to add features immediately and fix
(known) bugs later. I suppose I'll have to roll my own teTeX from now on.
Comment 5 jhs28 2001-07-25 06:31:44 EDT
I forwarded this bug detail to ASCII Corp. They have verified the bug and
provided a patch (see the URL below for the patch---notice that it will not be
available until tomorrow). It looks like this patch should make its way into
rawhide tetex (but as I haven't seen the patch, I have not tried it yet).

I have attached a mail I received from one of the ASCII Corp. developers. Please
note that they recommend that their patched version of dvips should NOT be
provided on the default version of any teTeX distribution. Furthermore, note
that on ASCII Corp's advice SuSE provides standard dvips as is and pdvips for
the patched Japanese one. I really think this is what RedHat should do (but
maybe with a more sensible name like dvipsj).


Regards, 

John 



==================================================

From hideak-t@ascii.co.jp Wed Jul 25 10:39:52 2001
Date: Wed, 25 Jul 2001 16:03:06 +0900
From: Hideaki Togashi <hideak-t@ascii.co.jp>
To: jhs28@eng.cam.ac.uk
Cc: www-ptex@ascii.co.jp, hideak-t@ascii.co.jp
Subject: Re: [www-ptex 1946] Re: dvipsk-jpatch-p1.5d wysiwyg error in
    mathmode

Hello, Mr. John H.Steele.

This is Hideaki Togashi of ASCII Corp. in Japan.

At last we may be able to specify the problem, we think.  Your ps
files and our Japanese TeX developers help us greatly.  Thank you very
much for your help.

Now we made the new Japanese patch to dvipsk.  For the time being, we
offer the new patch as beta version at the following URL;

 ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/beta/dvipsk-jpatch-p1.5e.tar.gz

This file will be placed tomorrow.

If you check this new patch and report the result to us, we will thank
you greatly again.

And if nobody report the bug, we plan to make this file open as
the official version of the new Japanese patch to dvipsk.

Thank you again.

By the way, is the Japanese patched dvips used as the only one dvips
on the RedHat Linux?  We do not recommend it.  When the SuSE Linux
cheam asked us, we answered the same.  So on the international version
of SuSE Linux 7.2, Japanese patched dvips is named 'pdvips', and 'dvips'
is the original one.

We cannot check all the environment, and like you this time, some
incompatibilities are reported sometimes.  When we get the reports we
try to do our best, but we cannot declare that Japanese patched dvips
is full compatible to the original one.

If you can, please tell the RedHat cheam not to use the japanese
patched dvips as the only one dvips.


Regards,

-- 
Hideaki Togashi <hideak-t@ascii.co.jp>



Comment 6 Tim Waugh 2001-08-03 06:48:18 EDT
Thank you very much for this feeback, and sorry for the delay in responding.  I
am about to build with this patch, and I will look at shipping two dvips programs.
Comment 7 Tim Waugh 2001-08-04 08:55:50 EDT
(The patch fixes the problem here.)
Comment 8 Tim Waugh 2001-08-07 13:26:01 EDT
Fixed in 1.0.7-27.

Note You need to log in before you can comment on or make changes to this bug.