Bug 467850 - initrd cannot handle 'options' in /etc/modprobe.conf, with spaces.
initrd cannot handle 'options' in /etc/modprobe.conf, with spaces.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
All Linux
high Severity medium
: rc
: 5.5
Assigned To: Peter Jones
Alexander Todorov
:
Depends On:
Blocks: 499522 531114
  Show dependency treegraph
 
Reported: 2008-10-21 06:25 EDT by Bryn M. Reeves
Modified: 2010-10-23 01:19 EDT (History)
17 users (show)

See Also:
Fixed In Version: 5.1.19.6-56
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 05:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix whitespace handling in nash (1.35 KB, patch)
2008-10-21 06:28 EDT, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Comment 1 Bryn M. Reeves 2008-10-21 06:28:18 EDT
Created attachment 320997 [details]
fix whitespace handling in nash

Patch from bug 219344 to correct whitespace handling in nash.
Comment 6 Peter Jones 2008-11-05 13:33:57 EST
Should be fixed in mkinitrd-5.1.19.6-40 .
Comment 11 Peter Jones 2008-11-25 16:36:45 EST
This patch isn't going to work -- it totally breaks all quote handling for other cases.  Another approach needs to be used.
Comment 12 Denise Dumas 2008-11-25 16:42:04 EST
Because we don't have a working fix for this, and the previous patch caused major regressions with raid and iscsi resulting in at least 4 additional bugzillas, I'm moving this to 5.4.  Clearly we need to rethink this, and the final days of 5.3 are not the correct time. But we certainly know the right test cases now!
Comment 14 Michael Kearey 2009-04-23 01:08:48 EDT
Comment on attachment 320997 [details]
fix whitespace handling in nash

Patch failed QA, so obsoleted
Comment 22 Denise Dumas 2009-10-30 12:55:09 EDT
Patch is in review
Comment 23 Denise Dumas 2009-11-02 08:57:13 EST
Patch review OK's this BZ - adding dev ack.
Comment 25 Peter Jones 2009-12-21 15:41:45 EST
This should be resolved in mkinitrd-5.1.19.6-56 .
Comment 28 Alexander Todorov 2010-01-04 05:15:07 EST
Verified by Hitachi as per comment #27. Changing status.
Comment 30 errata-xmlrpc 2010-03-30 05:00:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0295.html

Note You need to log in before you can comment on or make changes to this bug.