Bug 467875 - spacewalk-setup vs. spacewalk-dobby dependency problem
spacewalk-setup vs. spacewalk-dobby dependency problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Milan Zazrivec
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2008-10-21 09:42 EDT by Milan Zazrivec
Modified: 2009-09-10 14:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:53:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-10-21 09:42:27 EDT
spacewalk-setup package depends on spacewalk-dobby. In Satellite 5.3.0 composes
spacewalk-setup is located under Satellite/ directory, spacewalk-dobby under
EmbeddedDB/ directory. There are two problems with this setup:

1) Satellite on RHEL4: we don't have yum on RHEL4, all packages are installed
via install/installPackages.py, which is not able to deal with the fact that
spacewalk-dobby is in EmbeddedDB and exits the installation with unresolved
dependencies error.

2) Satellite ISO without embedded db: there's no EmbeddedDB dir and no
spacewalk-dobby package at all, which means that spacewalk-setup will report
unresolved dependencies problem (on both RHEL4 and RHEL5 ISO).
Comment 2 Devan Goodwin 2008-10-21 10:32:46 EDT
spacewalk-setup rebuilt without the spacewalk-dobby dependency in the satellite 5.3 tags for el4 and el5. New version of the package is 0.3.5-2.

The installPackages.py problem looks like it might be fixable by just installing the EmbeddedDB packages before those in Satellite. (currently it does the opposite) Going to make this change in svn and we'll give it a shot.

Fixed in svn revision: 178027
Comment 3 Devan Goodwin 2008-10-21 10:48:14 EDT
Change of plans, realized this change of order is not required now that we've broken deps and speaking with Jan it sounds like it may also cause problems. Revered this change in 178029.

ISO's to be rebuilt soon.
Comment 4 Milan Zazrivec 2008-11-12 06:21:22 EST
Verified with spacewalk-setup-0.3.6-2
Comment 5 Michael Mráka 2009-08-10 07:38:34 EDT
Verified in stage -> RELEASE_PENDING.

# rpm -qp Satellite/spacewalk-setup-0.5.27-19.el4sat.noarch.rpm --requires | grep -i dobby
# grep -ri dobby install*
# grep -ri db-control install*

Installation of satelite + external db (without spacewalk-dobby) works.
Comment 6 Brandon Perkins 2009-09-10 14:53:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.