Bug 46788 - CTL-C fails to cause ping to terminate.
Summary: CTL-C fails to cause ping to terminate.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-30 16:07 UTC by Derek Tattersall
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 20:31:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Tattersall 2001-06-30 16:07:31 UTC
Description of Problem:
CTL-C or CTL-D fails to cause ping to terminate.

How Reproducible:
Happens every time

Steps to Reproduce:
1. as a regular user: ping <another host>
2. 
3. 

Actual Results:
Continuous pings, which cannot be interrupted by CTL-C or CTL-D

Expected Results:
Terminate gracefully with summary statistcs of number of pings.

Additional Information:
iputils-20001110-4 (fairfax) has this problem.  iputils-20001110-1 in
seawolf behaves properly.

Comment 1 Derek Tattersall 2001-06-30 16:50:02 UTC
This only occurred after I upgraded from 7.1 to fairfax.  On a fresh install,
ping works as expected.

Comment 2 Phil Knirsch 2001-07-02 09:45:19 UTC
Did you only update iptuils to the fairfax version or did you make an update
installation?

I can't reproduce this bug on my completely updated 7.1 machine, thats why i ask.

Also, could you try to interrupt other programs from the shell you've been using
as it might not be strictly a iputils (ping) bug but maybe a shell missing job
control or with wrong tty settings.

An output of stty -a and rpm -q bash would be good as well.

Thanks,

Read ya, Phil

Comment 3 Glen Foster 2001-07-13 20:31:54 UTC
Derek, we need to get the data so we can tell if this is a SHOULD-FIX or not. 
Thanks!

Comment 4 Jay Turner 2002-02-13 19:44:26 UTC
Can replicate in the test lab, so closing this out.


Note You need to log in before you can comment on or make changes to this bug.