Bug 467886 - virt-manager depends on dbus-x11
virt-manager depends on dbus-x11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-10-21 10:35 EDT by Chris Snook
Modified: 2013-01-09 23:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 18:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2008-10-21 10:35:53 EDT
Description of problem:
If dbus-x11 is not installed, virt-manager will throw up a cryptic error suggesting that TCP/IP networking is disabled, and direct the user to gconf documentation, which doesn't make it obvious that dbus-x11 needs to be installed.

Version-Release number of selected component (if applicable):
virt-manager-0.6.0-2.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a minimal F10-Snap2 system, with virt-manager but no X or Gnome
2. ssh -X root@system from a system running X
3. Attempt to run virt-manager
  
Actual results:
A GUI window pops up with a hilariously wrong error message and suggests that the user consult documentation that is unrelated to the real problem.

Expected results:
virt-manager pulls in dbus-x11 automatically as a dependency

Additional info:
Fix is trivial, but the bug is rather baffling to the non-expert, particularly due to the error message.
Comment 1 Cole Robinson 2008-10-23 15:34:20 EDT
Thanks, fixed upstream:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=b9a48b071acb

I'll pull this in for rawhide.
Comment 2 Jesse Keating 2008-10-27 18:28:59 EDT
Verified the build done in koji.

Note You need to log in before you can comment on or make changes to this bug.