Bug 467891 - E: cpulimit.c: Recevied request to terminate due to CPU overload.
E: cpulimit.c: Recevied request to terminate due to CPU overload.
Status: CLOSED DUPLICATE of bug 462200
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-21 11:19 EDT by Jesse Kahtava
Modified: 2008-10-22 22:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 22:26:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PulseAudio output (6.90 KB, text/plain)
2008-10-21 11:19 EDT, Jesse Kahtava
no flags Details

  None (edit)
Description Jesse Kahtava 2008-10-21 11:19:30 EDT
Created attachment 321023 [details]
PulseAudio output

Description of problem:
PulseAudio is being run in system-wide mode (/usr/bin/pulseaudio -v --system --disallow-exit --disallow-module-loading 2> /var/log/pulse.log) and works fine for a long time, but eventually it will die with the following error:

Soft CPU time limit exhausted, terminating.
E: cpulimit.c: Recevied request to terminate due to CPU overload.
I: main.c: Daemon shutdown initiated.

I am running PA system-wide because the computer it's being used on is a headless system that my laptop connects to.

Version-Release number of selected component (if applicable):
pulseaudio 0.9.13

How reproducible:
It always happens though it usually takes a long time.

Steps to Reproduce:
1. Start PulseAudio with pulseaudio -v --system --disallow-exit --disallow-module-loading
2. Make it the default sink for my laptop by right clicking and choosing Default in the PA Volume utility.
3. Listen to music. Things usually work fine for a long time. Eventually PA dies.
  
Actual results:
PulseAudio terminates itself.

Expected results:
PulseAudio is expected to stay up and running.

Additional info:
Comment 1 Lennart Poettering 2008-10-22 22:26:16 EDT

*** This bug has been marked as a duplicate of bug 462200 ***

Note You need to log in before you can comment on or make changes to this bug.