Bug 467893 - Yum update cycles between ghc-prof and ghc682-prof
Yum update cycles between ghc-prof and ghc682-prof
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 11:28 EDT by Honza 'thingie' Bartoš
Modified: 2008-11-19 09:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:49:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza 'thingie' Bartoš 2008-10-21 11:28:46 EDT
Description of problem:
ghc-prof replaces ghc682-prof, but ghc682-prof also replaces ghc-prof. So first yum update will replace ghc-prof with ghc682-prof, next one will replace ghc682-prof with ghc-prof and so on...


Version-Release number of selected component (if applicable):
ghc-prof-6.8.3-8.fc10.i386 [rawhide repository]
ghc682-prof 6.8.2-2.fc9 [fedora repository]
fedora-release-9.92-1.noarch

Actual results:


Expected results:
Keep ghc-prof which is newer and version number is higher (most likely).


Additional info:
Comment 1 Jens Petersen 2008-10-21 18:56:27 EDT
Oh dear this is hard to fix and due to bad packaging: ghc682-prof should obsolete ghc-prof with version: unfortunately I don't see any way to fix this other than upgrading to f10, but the next f9 update of ghc may help to circumvent this since we're dropping ghc68X subpackaging.
Comment 2 Jens Petersen 2008-10-23 03:38:27 EDT
(In reply to comment #1)
> but the next f9 update of ghc may help to
> circumvent this since we're dropping ghc68X subpackaging.

No sorry that is nonsense.  Other than pushing a new ghc682 build (which is pretty much a wasted effort) I can see any good way to resolve this.  You could add system config to yum to ignore ghc682-prof to workaround around it (or uninstalled ghc-prof if that is an option).  Sorry.
Comment 3 Jens Petersen 2008-11-02 19:24:10 EST
> Other than pushing a new ghc682 build [...] I can['t] see any good way to resolve this.

And of course unfortunately it is not possible since ghc682 does not rebuild on f9. :-(
Comment 4 Jens Petersen 2008-11-03 01:34:12 EST
Okay I have an idea: perhaps for f9 we should just name the new ghc-prof-6.8.3 subpackage ghc683-prof instead to workaround this or maybe it is better to just add a dummy ghc682-prof package to keep yum quiet, otherwise we will break upgrades to f10 or need to update ghc for f10 to obsolete ghc683-prof.
Comment 5 Jens Petersen 2008-11-03 02:27:22 EST
Hopefully ghc-6.8.3-10.fc9 should fix this.
Comment 6 Fedora Update System 2008-11-03 03:13:24 EST
ghc-6.8.3-10.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ghc-6.8.3-10.fc9
Comment 7 Fedora Update System 2008-11-05 23:08:47 EST
ghc-6.8.3-10.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9388
Comment 8 Fedora Update System 2008-11-11 21:58:57 EST
ghc-6.8.3-10.fc9, gtk2hs-0.9.13-3.fc9, haddock-2.0.0.0-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghc gtk2hs haddock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9388
Comment 9 Fedora Update System 2008-11-19 09:49:04 EST
ghc-6.8.3-10.fc9, gtk2hs-0.9.13-3.fc9, haddock-2.0.0.0-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.