Bug 467896 - Cannot create virtual machine in virt-manager 0.6.0-2
Cannot create virtual machine in virt-manager 0.6.0-2
Status: CLOSED DUPLICATE of bug 467228
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 11:43 EDT by David Bensimon
Modified: 2008-10-21 15:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 15:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bensimon 2008-10-21 11:43:22 EDT
Description of problem:

Installed kvm and virt-manager using the instructions found here:
http://www.techotopia.com/index.php/Installing_and_Configuring_Fedora_KVM_Virtualization

Using virt-manager in an attempt to create an XP VM, I get to the final configuration step and when I press OK, i get the following error:

Unable to complete install '<type 'exceptions.UnboundLocalError'> local variable 'verr' referenced before assignment
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 722, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 730, in start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.5/site-packages/virtinst/FullVirtGuest.py", line 314, in _prepare_install
    distro = self.os_distro)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 264, in prepare
    self._prepare_cdrom(guest, distro, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 215, in _prepare_cdrom
    transient=True)
  File "/usr/lib/python2.5/site-packages/virtinst/VirtualDisk.py", line 135, in __init__
    self.__validate_params()
  File "/usr/lib/python2.5/site-packages/virtinst/VirtualDisk.py", line 369, in __validate_params
    self.__check_if_path_managed()
  File "/usr/lib/python2.5/site-packages/virtinst/VirtualDisk.py", line 348, in __check_if_path_managed
    "connection: %s" % (self.path, verr))
UnboundLocalError: local variable 'verr' referenced before assignment
'


Version-Release number of selected component (if applicable):

LSB Version:	:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch
Distributor ID:	Fedora
Description:	Fedora release 9.92 (Rawhide)
Release:	9.92
Codename:	Rawhide

Linux Kernel 2.6.27.3-27.rc1.fc10.i686

virt-manager-0.6.0-2.fc10.i386
libvirt-0.4.6-3.fc10.i386
kvm-74-4.fc10.i386
qemu-0.9.1-10.fc10.i386


Steps to Reproduce:
$ su -
$ yum install kvm qemu virt-manager
$ virt-manager
(Enter Password)
New VM - Default/ WinXP/4G HDD/512RAM/1CPU
OK -> Error: Unable to complete install '<type 'exceptions.UnboundLocalError'> local variable 'verr' referenced before assignment
  

Actual results:
Error

Unable to complete install '<type 'exceptions.UnboundLocalError'> local variable 'verr' referenced before assignment


Expected results:
VM Creation


Notes/Observations
I would like to know if I missed a step in setup or if this is in fact a bug. I do not see any groups relating to virtualization. Looking at some instructions I used when installing an older version of virt-manager on Ubuntu, I had to  also install package 'vde2' and add myself to the groups kvm, libvirtd and vde2-net.
Comment 1 Cole Robinson 2008-10-21 15:17:20 EDT
Hi, this is already fixed with the latest python-virtinst version in rawhide. Please see the bug this will be duped as.

*** This bug has been marked as a duplicate of bug 467228 ***

Note You need to log in before you can comment on or make changes to this bug.