Bug 467899 - Anaconda enforces archaic LVM1 extent limit on LVM2 logical volumes
Anaconda enforces archaic LVM1 extent limit on LVM2 logical volumes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: 6.0
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: AnacondaStorage
  Show dependency treegraph
 
Reported: 2008-10-21 12:13 EDT by Chris Snook
Modified: 2010-07-02 14:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-12.38.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 14:48:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2008-10-21 12:13:54 EDT
Description of problem:
The installer GUI will not let you create a logical volumes with more than 65536 logical extents.  This appears to be an attempt to enforce the LVM1 limit of 65534 extents per LV, which was lifted long ago.

Version-Release number of selected component (if applicable):
RHEL 5.2

How reproducible:
100%

Steps to Reproduce:
1. Start RHEL 5.2 installer in graphical mode
2. select custom disk layout
3. create a large PV (at least 64 GB)
4. create a VG with that large PV, and select a small extent size, such as 1 MB
5. Try to create a very large LV (> 64 GB)
  
Actual results:
Anaconda tells you it's limited to 65536 x extent size.

Expected results:
Anaconda lets you do whatever you want, since LVM2 does not have this restriction.

Additional info:
This artificially limits logical volumes to 2 TB with the default 32 MB extent size, or 8 TB with the maximum 128 MB extent size available in the LVM GUI.
Comment 1 Chris Lumens 2009-04-29 13:37:20 EDT
This should be fixed up in F11, which means it'll get pulled in for RHEL6.  I doubt we'll ever be able to isolate the set of commits that fix just this issue for backporting, since fixing this was part of a major storage rewrite we've been dealing with for a while now.  If you can, please test F11 out so we can make sure there's no outstanding problem for RHEL6.  Thanks.
Comment 4 Alexander Todorov 2010-05-24 10:30:00 EDT
Tested with anaconda-13.21.45-1.el6 in Xen domU. My setup is this:

- The domU backing store is a 100G file on the host
- In Anaconda UI I've created /boot (200MB) and a PV using all remaining space
- Created a VG with PE size 1MB and a LV for / with size 99850 MB. The rest is swap

Anaconda didn't issue any warnings or errors and happily proceeded with the install. The system was able to boot after install. 

Moving to VERIFIED.
Comment 5 releng-rhel@redhat.com 2010-07-02 14:48:17 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.