Bug 46790 - via-rhine net driver still not offered in the install textual menu, so kickstart over net fails
via-rhine net driver still not offered in the install textual menu, so kickst...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-30 12:49 EDT by Patrick Pollet
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 13:28:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Pollet 2001-06-30 12:49:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [fr] (WinNT; I)

Description of problem:
We are trying to do kickstart install over NFS on ~100 PC with netcard DFX530.
this card needs the via-rhine driver and works perfectly when the module is
installed by hand.
But this card is not detected by the setup program, and not offered in the
subsequent menu ( we got tulip, 3Com, hp100..as choices) but not via-rhine.
So our network installation are not possible.

I think this was already reported in 6.2 according to a google search.
Thanks for any followups


How reproducible:
Always

Steps to Reproduce:
1. boot on a install disk on a PC with DFX530.
2.
3.
	

Additional info:
Comment 1 Brent Fox 2001-07-03 12:17:38 EDT
I think that the via-rhine driver is on the drivers.img disk.  However, there
was a bug that prevents using kickstart with a driver disk.  That bug has been
fixed.  

If you are feeling adventurous, try downloading
people.redhat.com/bfox/bootnet.img.  Make a boot floppy with that and put your
kickstart file on the floppy too.  Boot from it and type 'linux dd ks=floppy'. 
It should start a kickstart install, but it should prompt you for the
drivers.img floppy first.  That way, it should pull in the via-rhine driver
before it connects to the network.  

Does that help?
Comment 2 Patrick Pollet 2001-07-04 09:00:14 EDT
Hello 
  
1)  The via rhine driver is indeed on the drivers.img . So pressing F2 at the screen
      of network card selection does the trick...with the old bootnet.cfg.

2)   I downloaded the new version of bootnet.img. Now linux dd ks=floppy DOES works
    as expected. That is the driver disk is asked at the very beginning... One step saved.

3)  I will have to check again but so far:
          - setting next_server and filename at the dhcp server 
          - or adding a nfs --server xxxx -- dir some_dir command in ks.cfg
      is not recognized by kickstart. One still has to type in the NFS server name and path

We have done 50 machines ( 25 using the original bootnet.img and 25 using the new bootnet.img)
  So the "bug" seems to be solved !

If you plan to release some sort of update for the via-rhine driver, you should consider adding the following
information:
   - with about 10 machines out of 50, the installation program stalls and never restart
at about 60-75% of installed packages due to the card timing out...
and not being able to find again the nfs server.
   adding the option "full_duplex=1" DID solve the problem in all cases.

Thanks for your help. Kickstart installation are really great !





Comment 3 Patrick Pollet 2001-07-06 07:31:06 EDT
Hello,

      I confirm my suspicion. the "new bootnet.img" from people.redhat.com/bfox ignores a nfs
command in ks.cfg when used with both dd and ks=floppy boot arguments.
      tested with the very same diskette on:
         -10  machines with a Dlink DF528 card recognized automatically as a ne2k-pci: the installation proceeds
             in full automatic mode ( no hands !).
         -75 machines with a Dlink DFX530TX, not recognized automatically.
                One has to use dd ks=floppy. After inserting the driver disk and loading the via-rhine driver
                with the option full_duplex=1, the dhcp procceeds as  expected but staff member 
                HAS to type in the nfs server name and installation path in the next screen.

 so the valid nfs command in ks.cfg is ignored in that case. 

Thanks for any  comments.
Comment 4 Brent Fox 2001-07-11 13:28:16 EDT
The updated boot disk doesn't have any changes in regards to the way kickstart
files are parsed.  This doesn't seem possible.  Literally, I only changed one
line of code.  Have you had any further luck with this issue?
Comment 5 Brent Fox 2001-07-23 11:50:00 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.