Bug 467901 - debuginfo-install requires the primary package to be installed
debuginfo-install requires the primary package to be installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 12:20 EDT by Jan Kratochvil
Modified: 2014-01-21 18:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 12:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-10-21 12:20:27 EDT
Description of problem:
I cannot run debuginfo-install if I have PKG-A and PKG-B installed but PKG uninstalled.  Surprisingly yum install PKG-debuginfo works.

Version-Release number of selected component (if applicable):
yum-utils-1.1.17-1.fc10.noarch
yum-3.2.19-5.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install some packages.
2. rpm -qa 'samba*'
3. debuginfo-install samba
BUT
4. yum -y install samba-debuginfo

Actual results:
2.
samba-client-3.2.4-0.22.fc10.x86_64
samba-common-3.2.4-0.22.fc10.x86_64
samba-winbind-3.2.4-0.22.fc10.x86_64
3.
Loaded plugins: priorities, refresh-packagekit, refresh-updatesd
rawhide-i386                                                                                            | 2.7 kB     00:00     
rawhide-debuginfo                                                                                       | 2.1 kB     00:00     
rawhide                                                                                                 | 2.7 kB     00:00     
Excluding Packages in global exclude list
Finished
enabling rawhide-debuginfo
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
No debuginfo packages available to install
BUT
4.
Loaded plugins: list-data, priorities, refresh-packagekit, refresh-updatesd
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package samba-debuginfo.x86_64 0:3.2.4-0.22.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================
 Package                        Arch                  Version                           Repository                        Size
===============================================================================================================================
Installing:
 samba-debuginfo                x86_64                3.2.4-0.22.fc10                   rawhide-debuginfo                 53 M

Transaction Summary
===============================================================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 53 M
Downloading Packages:

Expected results:
4. installs samba-debuginfo

Additional info:
Only asssuming the problem here is that the primary package samba is not installed.  debuginfo-install +/- works for other packages.
Comment 1 James Antill 2008-10-21 12:34:17 EDT
That's by design, you can do:

debuginfo-install 'samba*'

...or just use samba-client, both of which will get the samba-debuginfo package (and thus. bring in samba itself as a dep.)
Comment 2 Jan Kratochvil 2008-10-21 12:45:52 EDT
Hmm, in such case it is a GDB Bug now.  It suggests:

Missing separate debuginfos, use: debuginfo-install samba.x86_64

as it queries RPMTAG_SOURCERPM to assemble the list of debuginfo-install parameters shorter by unifying all required rpm subpackages debuginfos into a single parent package.
Comment 3 Jan Kratochvil 2008-11-02 22:35:18 EST
Committed to GDB Rawhide:
* Mon Nov  3 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-25
- Fix the debuginfo-install suggestions for missing base packages (BZ 467901),
  also update the rpm/yum code to no longer require _RPM_4_4_COMPAT.

Note You need to log in before you can comment on or make changes to this bug.