Bug 467909 - bbdb now notices old emails
bbdb now notices old emails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs-bbdb (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 12:52 EDT by Joe Bayes
Modified: 2008-11-22 11:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 22:35:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Bayes 2008-10-21 12:52:31 EDT
Description of problem:
With the most recent package of bbdb before the current one, bbdb would only "notice" New emails in VM. Selecting an unread or read message would not cause bbdb to add info in the message to the db, although it would display any records matching the info in the message. This was extremely useful because it meant that if I simply ignored any New spam, I could go back later (when it became marked Unread) and delete it, and bbdb would not add the spammers' addresses to the db. Now, bbdb "notices" addresses even in read (and unread) messages, so if I select a spam in order to delete it, bbdb adds the spammer's address to the db. This creates clutter. 

Version-Release number of selected component (if applicable):
emacs-bbdb-2.35-9.20080928cvs.fc9.noarch


How reproducible:
always

Steps to Reproduce:
1. Select a "read" message which contains info not in the db.
  
Actual results:
Info will be added to the db

Expected results:
Info will not be added to the db.

Additional info:
Comment 1 Jonathan Underwood 2008-10-23 09:58:34 EDT
This package had a major change by including the bbdb-vm.el(c) file which allows proper integration of VM and BBDB. So, checking the values of the variables listed in bbdb-vm.el (from emacs-bbdb.el) is the place to start. Eg. the variable vm-update-records-mode. That may not be it tho.

Please post your setup (i.e. relevant bits of .vm and .emacs).
Comment 2 Joe Bayes 2008-10-23 14:51:04 EDT
Erm. Yeah, here we go:

(defcustom bbdb/vm-update-records-mode
;  '(if (vm-new-flag msg) 'annotating 'searching)
  'annotating
 ...
)

Looks like someone isn't finished writing it yet.

It's been a while since I lisped, so I'm probably not getting the quoting right, but 

(setq bbdb/vm-update-records-mode
  (lambda nil
     (if (vm-new-flag msg) 'annotating 'searching)))

...doesn't seem to be working. But something like that should restore the old behavior. 

For now, (setq bbdb/vm-update-records-mode 'searching) at least keeps out the clutter. 

Thanks!
Comment 3 Jonathan Underwood 2008-10-23 15:05:16 EDT
OK. Actually, I think this problem is caused by this upstream change:

http://bbdb.cvs.sourceforge.net/viewvc/bbdb/bbdb/lisp/bbdb-vm.el?r1=1.105&r2=1.106

When I get chance I'll build new packages with that change reverted, as I think that'll resolve the issue properly.
Comment 4 Jonathan Underwood 2008-11-06 18:59:02 EST
OK, can you try removing (setq bbdb/vm-update-records-mode 'searching) from your init files and trying this build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=920330

to see if that fixes the problem - this package reverts the problematic change.

Thanks.
Comment 5 Fedora Update System 2008-11-06 19:09:05 EST
emacs-bbdb-2.36-0.1.20080928cvs.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.36-0.1.20080928cvs.fc10
Comment 6 Fedora Update System 2008-11-06 19:09:53 EST
emacs-bbdb-2.36-0.1.20080928cvs.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.36-0.1.20080928cvs.fc9
Comment 7 Joe Bayes 2008-11-06 19:29:37 EST
Erm -- no, I'm still having the same problem. 

spoo:/usr/share/emacs/site-lisp/bbdb$ rpm -q emacs-bbdb emacs-bbdb-el
emacs-bbdb-2.36-0.1.20080928cvs.fc9.noarch
emacs-bbdb-el-2.36-0.1.20080928cvs.fc9.noarch
spoo:/usr/share/emacs/site-lisp/bbdb$ 

The code that I posted in comment #2 is still unchanged in the bbdb-vm.el file, though.
Comment 8 Fedora Update System 2008-11-07 21:11:00 EST
emacs-bbdb-2.36-0.1.20080928cvs.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs-bbdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9504
Comment 9 Fedora Update System 2008-11-09 08:38:21 EST
emacs-bbdb-2.35-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-1.fc8
Comment 10 Fedora Update System 2008-11-09 08:39:26 EST
emacs-bbdb-2.35-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-1.fc9
Comment 11 Fedora Update System 2008-11-09 08:40:17 EST
emacs-bbdb-2.35-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-1.fc10
Comment 12 Jonathan Underwood 2008-11-09 08:42:09 EST
OK, I have reverted to the 2.35 release and patched it to install bbdb-vm.el(c). Can you try this package, hopefully we should be back to where we were before moving to the CVS head.

http://koji.fedoraproject.org/koji/buildinfo?buildID=68942
Comment 13 Fedora Update System 2008-11-11 21:52:10 EST
emacs-bbdb-2.35-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs-bbdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-9527
Comment 14 Fedora Update System 2008-11-11 21:56:26 EST
emacs-bbdb-2.35-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs-bbdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9572
Comment 15 Fedora Update System 2008-11-12 22:35:00 EST
emacs-bbdb-2.35-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-11-12 22:36:33 EST
emacs-bbdb-2.35-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2008-11-22 11:48:58 EST
emacs-bbdb-2.35-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.