Bug 467933 - kdegraphics src.rpm doesn't build
kdegraphics src.rpm doesn't build
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 14:34 EDT by Bob Tennent
Modified: 2008-10-28 05:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 17:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Tennent 2008-10-21 14:34:44 EDT
Description of problem: libgphoto2-port isn't found:

CMake Error: Parse error in cache file /usr/src/redhat/BUILD/kdegraphics-4.1.2/i386-redhat-linux-gnu/CMakeCache.txt. Offending entry: Perhaps you should add the directory containing `libgphoto2-port.pc'
CMake Error: Parse error in cache file /usr/src/redhat/BUILD/kdegraphics-4.1.2/i386-redhat-linux-gnu/CMakeCache.txt. Offending entry: to the PKG_CONFIG_PATH environment variable
CMake Error: Parse error in cache file /usr/src/redhat/BUILD/kdegraphics-4.1.2/i386-redhat-linux-gnu/CMakeCache.txt. Offending entry: No package 'libgphoto2-port' found;general;-lgphoto2 -lgphoto2_port -lexif -lm -lusb;
CMake Error: Parse error in cache file /usr/src/redhat/BUILD/kdegraphics-4.1.2/i386-redhat-linux-gnu/CMakeCache.txt. Offending entry: Perhaps you should add the directory containing `libgphoto2-port.pc'
CMake Error: Parse error in cache file /usr/src/redhat/BUILD/kdegraphics-4.1.2/i386-redhat-linux-gnu/CMakeCache.txt. Offending entry: to the PKG_CONFIG_PATH environment variable
CMake Error: Parse error in cache file /usr/src/redhat/BUILD/kdegraphics-4.1.2/i386-redhat-linux-gnu/CMakeCache.txt. Offending entry: No package 'libgphoto2-port' found;general;-lgphoto2 -lgphoto2_port -lexif -lm -lusb;
Re-run cmake error reading : CMakeFiles/Makefile.cmake



Version-Release number of selected component (if applicable):

kdegraphics-4.1.2 (also 4.1.1)


How reproducible: every time


Steps to Reproduce:
1. rpmbuild -bb kdegraphics.spec
2.
3.
  
Actual results:

As above.


Expected results:

kdegraphics-4.1.2-x.fc9.i386.rpm



Additional info:


% rpm -qa | grep gphoto2
libgphoto2-devel-2.4.1-2.99.fc9.i386
libgphoto2-2.4.1-2.99.fc9.i386
sane-backends-libs-gphoto2-1.0.19-10.fc9.i386

% ls -l libgphoto2*
  0 lrwxrwxrwx 1 root root     24 2008-09-10 15:48 libgphoto2_port.so -> libgphoto2_port.so.0.8.0*
  0 lrwxrwxrwx 1 root root     24 2008-09-26 11:39 libgphoto2_port.so.0 -> libgphoto2_port.so.0.8.0*
 32 -rwxr-xr-x 1 root root  32340 2008-06-22 13:50 libgphoto2_port.so.0.8.0*
  0 lrwxrwxrwx 1 root root     19 2008-09-10 15:48 libgphoto2.so -> libgphoto2.so.2.3.0*
  0 lrwxrwxrwx 1 root root     19 2008-09-26 11:39 libgphoto2.so.2 -> libgphoto2.so.2.3.0*
120 -rwxr-xr-x 1 root root 115872 2008-06-22 13:50 libgphoto2.so.2.3.0*

libgphoto2:
total 28
 4 drwxr-xr-x 2 root root  4096 2008-09-26 11:39 2.4.1/
24 -rwxr-xr-x 1 root root 20668 2008-06-22 13:50 print-camera-list*

libgphoto2_port:
total 4
4 drwxr-xr-x 2 root root 4096 2008-09-26 11:39 0.8.0/


% rpm -qf /usr/lib/libgphoto2*
libgphoto2-2.4.1-2.99.fc9.i386
libgphoto2-2.4.1-2.99.fc9.i386
libgphoto2-devel-2.4.1-2.99.fc9.i386
libgphoto2-2.4.1-2.99.fc9.i386
libgphoto2-2.4.1-2.99.fc9.i386
libgphoto2-devel-2.4.1-2.99.fc9.i386
libgphoto2-2.4.1-2.99.fc9.i386
libgphoto2-2.4.1-2.99.fc9.i386
Comment 1 Rex Dieter 2008-10-21 17:10:38 EDT
It clearly *does* build, else, we wouldn't have been able to produce a kde-4.1.2 update that includes it.

Maybe you can compare your build logs against that from a clean buildroot as used from koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=65226

On quick glance, you may need gphoto2-devel installed, which is included as a build requirement for this pkg.
Comment 2 Bob Tennent 2008-10-21 19:15:51 EDT
"you may need gphoto2-devel installed, which is included as a build requirement for this pkg."

Trying to install gphoto2-devel using yum yields

   Package gphoto2-devel is obsoleted by libgphoto2, trying to install    libgphoto2-2.4.1-2.99.fc9.i386 instead
  Package libgphoto2-2.4.1-2.99.fc9.i386 already installed and latest version
  Nothing to do

So that doesn't seem to be the problem.

"compare your build logs against a clean buildroot..."

The difference is here:

-- Found gphoto2: Package libgphoto2-port was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgphoto2-port.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgphoto2-port' found;-lgphoto2 -lgphoto2_port -lexif -lm -lusb

whereas it should be

-- Found gphoto2: -lgphoto2 -lgphoto2_port -lm;-lgphoto2 -lgphoto2_port -lm


Why is it looking for a libgphoto2-port *package*?

If I comment out the two gphoto2 lines in CMakeLists.txt, kdegraphics builds OK.
Comment 3 Kevin Kofler 2008-10-21 20:16:03 EDT
It's looking for a libgphoto2-port pkg-config "package", which is not the same as a Fedora package.

I can only presume libgphoto2 broke compatibility and thus broke the kdegraphics build.
Comment 4 Bob Tennent 2008-10-21 22:15:07 EDT
"I can only presume libgphoto2 broke compatibility and thus broke the
kdegraphics build."

I didn't understand this comment until I realized that the libgphoto2[-devel]-2.4.1 rpms
aren't from fedora-updates but from atrpms, updated automatically by yum. I've entered a bug report at the atrpms bugzilla.
Comment 5 Kevin Kofler 2008-10-21 22:37:05 EDT
Looks like ATrpms backported a broken revision from Rawhide, it's missing my fix for this very issue:
http://cvs.fedoraproject.org/viewvc/rpms/libgphoto2/devel/libgphoto2.spec?r1=1.8&r2=1.10
http://cvs.fedoraproject.org/viewvc/rpms/libgphoto2/devel/gphoto2-pkgcfg.patch?r1=1.2&r2=1.4

It's also otherwise outdated (2.4.1, Rawhide has 2.4.3), but that's not that big an issue (after all, official F9 only has 2.4.0), the fact that the gphoto2-config script is broken is.
Comment 6 Axel Thimm 2008-10-28 05:00:53 EDT
(In reply to comment #5)
> Looks like ATrpms backported a broken revision from Rawhide, it's missing my
> fix for this very issue:
> http://cvs.fedoraproject.org/viewvc/rpms/libgphoto2/devel/libgphoto2.spec?r1=1.8&r2=1.10
> http://cvs.fedoraproject.org/viewvc/rpms/libgphoto2/devel/gphoto2-pkgcfg.patch?r1=1.2&r2=1.4

Thanks!

> It's also otherwise outdated (2.4.1, Rawhide has 2.4.3), but that's not that
> big an issue (after all, official F9 only has 2.4.0), the fact that the
> gphoto2-config script is broken is.

I needed to go 2.4.1 to fix broken Canon import (bug #443515 and bug #447290), and jnovy wanted to upgrade F9's gphoto since about June, so I created an intermediate package (less than rawhide's evr) to get myself and some others going.

I don't want to get 2.4.3 into ATrpms, I'd love to see an updated package in F9, so I can withdraw gphoto from ATrpms again. :(

I'll apply Kevin's fix to ATrpms' packages in the mean time, thanks again!

Note You need to log in before you can comment on or make changes to this bug.