Bug 467987 - "Add/Remove Software" window is either maximized or tiny, and not resizeable
"Add/Remove Software" window is either maximized or tiny, and not resizeable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-22 01:32 EDT by sangu
Modified: 2013-01-09 23:51 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.3.9-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 01:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
window size is too small. (29.12 KB, image/png)
2008-10-22 01:32 EDT, sangu
no flags Details
gpk-application --verbose log (5.19 KB, text/plain)
2008-10-27 14:25 EDT, Matthias Clasen
no flags Details

  None (edit)
Description sangu 2008-10-22 01:32:17 EDT
Created attachment 321113 [details]
window size is too small.

Description of problem:
gpk-application window size is unusable(too small) and unchangeable.
size is 311x220.

$ xwininfo 

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x5600004 "Add/Remove Software"

  Absolute upper-left X:  776
  Absolute upper-left Y:  511
  Relative upper-left X:  776
  Relative upper-left Y:  511
  Width: 311
  Height: 220

Version-Release number of selected component (if applicable):
0.3.8-1.fc10

How reproducible:
always

Steps to Reproduce:
1. Launch Add/Remove Software
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Will Woods 2008-10-23 14:55:26 EDT
On most systems it's maximized - still unchangeable though. Dragging the maximized window causes it to become tiny-size.
Comment 2 Richard Hughes 2008-10-24 05:33:49 EDT
Building a fix for rawhide now: http://koji.fedoraproject.org/koji/taskinfo?taskID=900511

If this fails to fix the problem, please re-open this bug. Thanks.
Comment 3 sangu 2008-10-24 10:03:24 EDT
Patch 1, 2 do not apply to gnome-packagekit.spec(0.3.8-2.fc10).
http://cvs.fedoraproject.org/viewvc/devel/gnome-packagekit/gnome-packagekit.spec?revision=1.56&view=markup
[skip]
# Upstream: cc6ecacb62f66bbe4ce71f14583e108d6026b20f
Patch1:    gpk~fix-resize-small-form-factor.patch

# Upstream: 95e5c1d6c104ea395c3dde9da4a6c327c05ec378
Patch2:    gpk-untitled-window.patch
[skip]

%prep
%setup -q
%patch0 -p1
#%patch1 -p1
Comment 4 Will Woods 2008-10-24 16:59:54 EDT
Actually applying the patches successfully *does* gpk-application resizeable, but it still starts out maximized. 

Hitting the "unmaximize" button makes it unusably tiny. And it doesn't remember its size or position between uses, so you have to Unmaximize+ Resize-to-usable-size the window every time.
Comment 5 Richard Hughes 2008-10-27 09:11:18 EDT
I think I've fixed this in rawhide -- can you please re-open if it still does not work? Thanks.
Comment 6 Will Woods 2008-10-27 13:23:32 EDT
gnome-packagekit-0.3.9-1.fc10.i386 still exhibits the behavior from comment #4 - gpk-application *is* resizeable now, but:

a) always starts maximized, and
b) when unmaximized, becomes unusably small.
Comment 7 Matthias Clasen 2008-10-27 14:25:22 EDT
Created attachment 321639 [details]
gpk-application --verbose log

The log shows gpk-application using 'small formfactor mode' on my 1920x1200 display...
Comment 8 Richard Hughes 2008-10-27 17:50:19 EDT
Ahh, I've patched 0.3.9-3 to fix the size request -- it was a stupid typo on my part, apologies. I didn't hit this as I run my setup in a double-wide screen.

This now works for me (tested on two machines) but please reopen if 0.3.9-3 doesn't completely fix things.
Comment 9 Will Woods 2008-10-27 18:12:06 EDT
Either I'm testing it wrong, or it's still not working.

[wwoods@metroid ~]$ gpk-application --version
0.3.9
[wwoods@metroid ~]$ rpm -q gnome-packagekit
gnome-packagekit-0.3.9-3.fc10.i386
[wwoods@metroid ~]$ gpk-application -v
...
TI:18:08:17	TH:0x955b3f0	FI:gpk-common.c	FN:gpk_window_set_size_request,55
 - using small form factor mode

My monitor's 1680x1050, for the record.
Comment 10 Jesse Keating 2008-10-27 18:37:39 EDT
I really don't think this is a preview blocker.  Moving over to F10Blocker.
Comment 11 Richard Hughes 2008-10-27 19:01:49 EDT
Thanks for testing this so fast Will -- apologies, I'm getting sleepy here:

* Mon Oct 27 2008 Richard Hughes  <rhughes@redhat.com> - 0.3.9-4
- Barr. Actually apply the patch. Sleep time.

Can you retry 0.3.9-4 please? Thanks.
Comment 12 Will Woods 2008-10-28 01:06:45 EDT
No apologies necessary - rumor has it you're only human. :)

0.3.9-4 works as expected. Closing.

Note You need to log in before you can comment on or make changes to this bug.