Bug 467992 - define ISANAME and ISABIT for sh architecture
define ISANAME and ISABIT for sh architecture
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
sh4 Linux
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 02:37 EDT by CHIKAMA Masaki
Modified: 2008-10-22 04:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 04:16:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm-4.6.0-sh-linux.patch (401 bytes, patch)
2008-10-22 02:38 EDT, CHIKAMA Masaki
no flags Details | Diff
rpm-4.6.0-shisa.patch (280 bytes, patch)
2008-10-22 02:39 EDT, CHIKAMA Masaki
no flags Details | Diff

  None (edit)
Description CHIKAMA Masaki 2008-10-22 02:37:04 EDT
Description of problem:

 This patch defines ISANAME and ISABITS so that it makes rpmbuild
stop the following message.

> error: Macro %__isa_name has empty body
> error: Macro %__isa_bits has empty body

It also needs for rpmbuild to produce debuginfo package.

--- rpm-4.6.0-rc1/installplatform.org   2008-10-21 14:46:48.000000000 +0900
+++ rpm-4.6.0-rc1/installplatform       2008-10-22 10:00:22.000000000 +0900
@@ -116,6 +116,10 @@
        ISANAME=ia
        ISABITS=64
        ;;
+    sh*)
+       ISANAME=sh
+       ISABITS=32
+       ;;
   esac
                                                                                
   if [ -n "$MULTILIBNO" ]; then


I also revised patch for rpm-4.6.0-rc1 which didn't include in
Bug #432496.


Version-Release number of selected component (if applicable):
 rpm-4.6.0-0.rc1.2
Comment 1 CHIKAMA Masaki 2008-10-22 02:38:53 EDT
Created attachment 321118 [details]
rpm-4.6.0-sh-linux.patch

add option to optflag.
Comment 2 CHIKAMA Masaki 2008-10-22 02:39:45 EDT
Created attachment 321119 [details]
rpm-4.6.0-shisa.patch
Comment 3 Jindrich Novy 2008-10-22 03:31:37 EDT
Both patches are now applied in upstream, thanks for them.

Just a quick question. Since I have no access to SH arches, what problems do you see when the IEEE compliance flag is missing from CFLAGS?
Comment 4 CHIKAMA Masaki 2008-10-22 03:53:47 EDT
(In reply to comment #3)
> Both patches are now applied in upstream, thanks for them.
> 
> Just a quick question. Since I have no access to SH arches, what problems do
> you see when the IEEE compliance flag is missing from CFLAGS?

I found the perl and mpfr package didn't pass self test without it.
After that, I alwasys build packages using patched rpm ,so I don't
know other packages which really need this option.
Comment 5 CHIKAMA Masaki 2008-10-22 04:08:09 EDT
Here are build log which I had found.

a part of mpfr-2.3.0-1.fc8 's build log

PASS: tset_exp
PASS: tset
PASS: tabs
tset_d.c:76:  assertion failed: (!(((d) >= 0.0) + ((d) <= 0.0)))
/bin/sh: line 4:  1005 Aborted                 MPFR_QUIET=1 ${dir}$tst
FAIL: tset_d
PASS: tset_f
  ..... 
PASS: tcmp2
PASS: tcmpabs
/bin/sh: line 4:  1306 Terminated              MPFR_QUIET=1 ${dir}$tst
FAIL: tcmp_d
PASS: tcmp_ld


a part of perl-5.8.8-30.fc8 's build log

t/op/chr..................................ok
t/op/closure..............................ok
t/op/cmp..................................FAILED at test 46
t/op/concat...............................ok
t/op/cond.................................ok
Comment 6 Jindrich Novy 2008-10-22 04:16:18 EDT
Seems like a good reason to add it then. Thanks for the patches again :)

Note You need to log in before you can comment on or make changes to this bug.