This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 467997 - collectd uses udp
collectd uses udp
Status: CLOSED WORKSFORME
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mo Morsi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 05:24 EDT by Gerd Hoffmann
Modified: 2014-07-06 15:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 23:49:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2008-10-22 05:24:54 EDT
Description of problem:
collectd uses the udp protocol,
the dns service records are _collectd._tcp though.

Version-Release number of selected component (if applicable):
0.94, both server appliance (announce) and node (search).
Comment 1 Mo Morsi 2009-05-26 15:33:46 EDT
Not fully sure I understand the issue (if it is still an issue). 

Which components running on which machines are failing to communicate due to the transport protocol mismatch? Is this an issue w/ collectd itself or how we are configuring it in ovirt? What relies on this that's being affected?

If you could elaborate, I'd appreciate it.
Comment 2 Alan Pevec 2009-05-27 07:08:31 EDT
It's just a misnomer, collectd uses UDP.
It doesn't break anything, but should be fixed regardless, for correctness sake:
just change default dnsmasq config and lookups in the ovirt-node scripts.
Comment 3 Mo Morsi 2009-05-27 18:31:46 EDT
Sorry this took so long, was thrown off by the project the fix should be in. Shouldn't the change be in the server project? As the server installer sets up /etc/dnsmasq.d/ovirt-dns.conf which contains the incorrect collectd entry. 

In any case, I just send this out which I believe resolves the issue:

https://www.redhat.com/archives/ovirt-devel/2009-May/msg00222.html
Comment 4 Mo Morsi 2009-05-28 12:32:01 EDT
Changes to the node to use the new dns entry, based on alan's feedback

https://www.redhat.com/archives/ovirt-devel/2009-May/msg00238.html
Comment 5 Mo Morsi 2009-05-28 23:49:52 EDT
Committed and resolved

Note You need to log in before you can comment on or make changes to this bug.