Bug 468033 - sectool missing dependancy on "which"
sectool missing dependancy on "which"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sectool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 10:18 EDT by Michael Cutler
Modified: 2008-10-23 11:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 11:42:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks.cfg (1.03 KB, application/configuration)
2008-10-22 10:19 EDT, Michael Cutler
no flags Details
install.log (12.64 KB, application/octet-stream)
2008-10-22 10:19 EDT, Michael Cutler
no flags Details
sectool output (1.90 KB, application/octet-stream)
2008-10-22 10:20 EDT, Michael Cutler
no flags Details

  None (edit)
Description Michael Cutler 2008-10-22 10:18:30 EDT
Description of problem:

  Another edge condition, but I think sectool is missing a couple of dependancies from its RPM description. A minimal install from Fedora-10-Snap2-i386-DVD.iso (text-mode) where all packages are deselected excludes 'cron' and 'which'. Installing sectool using "yum install sectool" picks up dependancies on 'gettext' and 'libgomp'. First run of "sectool --level 1" produced:

group ->
    Warning: Test group has missing dependencies: which
    group: INVALID

passwd ->
    Warning: Test passwd has missing dependencies: which
    passwd: INVALID

shadow ->
    Warning: Test shadow has missing dependencies: which
    shadow: INVALID

home_dirs ->
    Warning: Test home_dirs has missing dependencies: which
    home_dirs: INVALID
(...cut...)
cron ->
    Error: Missing file or directory: "/etc/cron.d" (cron directory)
    Error: Missing file or directory: "/etc/cron.hourly" (cron directory)
    Error: Missing file or directory: "/etc/cron.weekly" (cron directory)
    Error: Missing file or directory: "/etc/cron.monthly" (cron directory)
    cron: ERROR


Version-Release number of selected component (if applicable):

  sectool-0.9.0-1.fc10.i386.rpm (Fedora-10-Snap2-i386-DVD.iso)

How reproducible:

  Every time.

Steps to Reproduce:
1. Bare minimal install from Fedora-10-Snap2-i386-DVD.iso (text-mode) all packages deselected.
2. "yum install sectool"
3. "sectool --level 1"
  
Actual results:

  Errors caused by missing dependancy 'which', errors because 'cron' not installed.

Expected results:

  Add 'which' to the RPM dependancies. Skip 'cron' test if its not installed.

Additional info:
Comment 1 Michael Cutler 2008-10-22 10:19:01 EDT
Created attachment 321155 [details]
anaconda-ks.cfg
Comment 2 Michael Cutler 2008-10-22 10:19:28 EDT
Created attachment 321156 [details]
install.log
Comment 3 Michael Cutler 2008-10-22 10:20:12 EDT
Created attachment 321157 [details]
sectool output
Comment 4 Peter Vrabec 2008-10-23 11:42:16 EDT
fixed in sectool-0.9.1-2
thnx. for report.

Note You need to log in before you can comment on or make changes to this bug.