This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468045 - Interface name too long: "ioctl 35123 returned -1"
Interface name too long: "ioctl 35123 returned -1"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 11:06 EDT by Benny Amorsen
Modified: 2008-11-05 23:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 23:05:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benny Amorsen 2008-10-22 11:06:13 EDT
Description of problem:
snmpd does not understand interface names longer than 8 symbols. This causes a lot of logs like:

Oct 22 17:01:16 router01 snmpd[14634]: ioctl 35123 returned -1



Version-Release number of selected component (if applicable):
net-snmp-5.4.1-18.fc9.x86_64

Additional info:
According to http://www.mail-archive.com/net-snmp-users@lists.sourceforge.net/msg18879.html the problem is solved in 5.4.2.

Rawhide does not have 5.4.2, unfortunately.
Comment 1 Jan Safranek 2008-10-23 03:53:08 EDT
(In reply to comment #0)
> Rawhide does not have 5.4.2, unfortunately.

5.4.2 was submitted to Rawhide one month ago! Anyway, I update F9 net-snmp when more bugs come.
Comment 2 Benny Amorsen 2008-10-23 09:36:59 EDT
You are right, Rawhide has 5.4.2. For some reason my laptop won't pick it up with yum though. When I look at the repository in a web browser, the file is clearly there.

Anyway, /usr/sbin/snmpd depends on librpm, and librpm has changed soname between F9 and Rawhide. I guess I'll have to wait for F10.
Comment 3 Fedora Update System 2008-11-03 04:34:55 EST
net-snmp-5.4.1-19.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/net-snmp-5.4.1-19.fc9
Comment 4 Fedora Update System 2008-11-05 23:05:43 EST
net-snmp-5.4.1-19.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.