Bug 468046 - newt interprets shift-tab as escape on vt320
newt interprets shift-tab as escape on vt320
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: newt (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Lichvar
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 11:09 EDT by Olivier Fourdan
Modified: 2013-04-12 15:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 04:40:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add the required binding for VT320 (405 bytes, patch)
2008-10-22 11:09 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2008-10-22 11:09:04 EDT
Created attachment 321165 [details]
Add the required binding for VT320

Description of problem:

On VT320 terminals, shift-tab generates the escape sequence "^[[Z" which is interpreted as "Escape" by newt.

Version-Release number of selected component (if applicable):

newt-0.52.2

How reproducible:

100% reproducible

Steps to Reproduce:
1. run "xterm"
2. set TERM=vt320
3. run /usr/share/doc/newt-devel-*/peanuts.py
4. press shift-tab
  
Actual results:

The dialog quits w/out selection

Expected results:

The previous field gets selected

Additional info:

This affects Anaconda during remote installation from a terminal.

The attached patch provided by our partner adds the required key code to the untab binding. I rebuilt a test package with this patch and detected no regression using the regular vt220 terminal, while it fixed the issue with vt320.
Comment 1 Miroslav Lichvar 2008-10-22 11:50:59 EDT
I'm not sure the steps to reproduce are valid, xterm is not a vt320 terminal.

If it's reproducible on a real vt320 terminal, maybe we should fix it in termcap/terminfo by adding kB/kcbt entries?

On the other hand, ending the form by pressing escape key actually is a bug. Recent newt versions ignore escape by default.
Comment 2 RHEL Product and Program Management 2009-03-26 12:49:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Issue Tracker 2009-07-30 14:49:47 EDT
Event posted on 2009-07-29 14:42 EDT by Glen Johnson

------- Comment From hamzy@us.ibm.com 2009-07-29 14:39 EDT-------
According to Arthur, this happens during the initial install when the
customer is using the java command window console provided by the HMC.

I have verified that this does not fail when using an xterm window.

Ticket type changed from 'Problem' to ''

This event sent from IssueTracker by balkov 
 issue 225824
Comment 4 Issue Tracker 2009-08-03 10:08:24 EDT
Event posted on 2009-07-30 15:23 EDT by Glen Johnson

------- Comment From hamzy@us.ibm.com 2009-07-30 15:11 EDT-------
Okay, here is some more information.

I tried to reproduce this problem during the first stage of an install
with the java console window via IE.  I could not reproduce the problem.

I learned that you can also access a console window by sshing into the HMC
and using the vtmenu program.  I used Cygwin's xterminal to access vtmenu
and was able to reproduce the problem!  I can also use an xterm from a
Fedora 11 machine and be able to reproduce the problem.


This event sent from IssueTracker by balkov 
 issue 225824
Comment 5 Issue Tracker 2009-08-03 10:08:26 EDT
Event posted on 2009-07-31 17:01 EDT by Glen Johnson

------- Comment From hamzy@us.ibm.com 2009-07-31 16:51 EDT-------
I came across a Debian defect
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=72236 that talks about
shift-tab being added to the xterm capabilities file.  I have verified
that this is in Fedora 11's capability file.

[root@hamzy2 ~]# infocmp
#       Reconstructed via infocmp from file: /usr/share/terminfo/x/xterm
xterm|xterm terminal emulator (X Window System),
am, bce, km, mc5i, mir, msgr, npc, xenl,
colors#8, cols#80, it#8, lines#24, pairs#64,
acsc=``aaffggiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
bel=^G, blink=\E[5m, bold=\E[1m, cbt=\E[Z, civis=\E[?25l,
clear=\E[H\E[2J, cnorm=\E[?12l\E[?25h, cr=^M,
csr=\E[%i%p1%d;%p2%dr, cub=\E[%p1%dD, cub1=^H,
cud=\E[%p1%dB, cud1=^J, cuf=\E[%p1%dC, cuf1=\E[C,
cup=\E[%i%p1%d;%p2%dH, cuu=\E[%p1%dA, cuu1=\E[A,
cvvis=\E[?12;25h, dch=\E[%p1%dP, dch1=\E[P, dl=\E[%p1%dM,
dl1=\E[M, ech=\E[%p1%dX, ed=\E[J, el=\E[K, el1=\E[1K,
flash=\E[?5h$<100/>\E[?5l, home=\E[H, hpa=\E[%i%p1%dG,
ht=^I, hts=\EH, ich=\E[%p1%d@, il=\E[%p1%dL, il1=\E[L,
ind=^J, indn=\E[%p1%dS, invis=\E[8m,
is2=\E[!p\E[?3;4l\E[4l\E>, kDC=\E[3;2~, kEND=\E[1;2F,
kHOM=\E[1;2H, kIC=\E[2;2~, kLFT=\E[1;2D, kNXT=\E[6;2~,
kPRV=\E[5;2~, kRIT=\E[1;2C, kb2=\EOE, kbs=\177, kcbt=\E[Z,
kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC, kcuu1=\EOA,
kdch1=\E[3~, kend=\EOF, kent=\EOM, kf1=\EOP, kf10=\E[21~,
kf11=\E[23~, kf12=\E[24~, kf13=\E[1;2P, kf14=\E[1;2Q,
kf15=\E[1;2R, kf16=\E[1;2S, kf17=\E[15;2~, kf18=\E[17;2~,
kf19=\E[18;2~, kf2=\EOQ, kf20=\E[19;2~, kf21=\E[20;2~,
kf22=\E[21;2~, kf23=\E[23;2~, kf24=\E[24;2~,
kf25=\E[1;5P, kf26=\E[1;5Q, kf27=\E[1;5R, kf28=\E[1;5S,
kf29=\E[15;5~, kf3=\EOR, kf30=\E[17;5~, kf31=\E[18;5~,
kf32=\E[19;5~, kf33=\E[20;5~, kf34=\E[21;5~,
kf35=\E[23;5~, kf36=\E[24;5~, kf37=\E[1;6P, kf38=\E[1;6Q,
kf39=\E[1;6R, kf4=\EOS, kf40=\E[1;6S, kf41=\E[15;6~,
kf42=\E[17;6~, kf43=\E[18;6~, kf44=\E[19;6~,
kf45=\E[20;6~, kf46=\E[21;6~, kf47=\E[23;6~,
kf48=\E[24;6~, kf49=\E[1;3P, kf5=\E[15~, kf50=\E[1;3Q,
kf51=\E[1;3R, kf52=\E[1;3S, kf53=\E[15;3~, kf54=\E[17;3~,
kf55=\E[18;3~, kf56=\E[19;3~, kf57=\E[20;3~,
kf58=\E[21;3~, kf59=\E[23;3~, kf6=\E[17~, kf60=\E[24;3~,
kf61=\E[1;4P, kf62=\E[1;4Q, kf63=\E[1;4R, kf7=\E[18~,
kf8=\E[19~, kf9=\E[20~, khome=\EOH, kich1=\E[2~,
kind=\E[1;2B, kmous=\E[M, knp=\E[6~, kpp=\E[5~,
kri=\E[1;2A, mc0=\E[i, mc4=\E[4i, mc5=\E[5i, meml=\El,
memu=\Em, op=\E[39;49m, rc=\E8, rev=\E[7m, ri=\EM,
rin=\E[%p1%dT, rmacs=\E(B, rmam=\E[?7l, rmcup=\E[?1049l,
rmir=\E[4l, rmkx=\E[?1l\E>, rmm=\E[?1034l, rmso=\E[27m,
rmul=\E[24m, rs1=\Ec, rs2=\E[!p\E[?3;4l\E[4l\E>, sc=\E7,
setab=\E[4%p1%dm, setaf=\E[3%p1%dm,
setb=\E[4%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
setf=\E[3%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
sgr=%?%p9%t\E(0%e\E(B%;\E[0%?%p6%t;1%;%?%p2%t;4%;%?%p1%p3%|%t;7%;%?%p4%t;5%;%?%p7%t;8%;m,
sgr0=\E(B\E[m, smacs=\E(0, smam=\E[?7h, smcup=\E[?1049h,
smir=\E[4h, smkx=\E[?1h\E=, smm=\E[?1034h, smso=\E[7m,
smul=\E[4m, tbc=\E[3g, u6=\E[%i%d;%dR, u7=\E[6n,
u8=\E[?1;2c, u9=\E[c, vpa=\E[%i%p1%dd,

The key fields are:

cbt=\E[Z
kcbt=\E[Z

This sounds like a reasonable fix for newt to intercept and handle
"\033[Z".

Can we get RedHat to look into this again?


This event sent from IssueTracker by balkov 
 issue 225824
Comment 13 errata-xmlrpc 2009-10-07 04:40:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1482.html

Note You need to log in before you can comment on or make changes to this bug.