Bug 468054 - bashrc not run when running non-interactive remote shell
bashrc not run when running non-interactive remote shell
Status: CLOSED DUPLICATE of bug 458839
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 11:39 EDT by David Mansfield
Modified: 2008-10-22 13:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 13:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mansfield 2008-10-22 11:39:21 EDT
Description of problem:
If a remote program is executed, say 'ssh localhost date', the bashrc script is supposed to be run.  (See the manpage for 'bash' and see also bash shell.c:970).

For some reason this is not happening with openssh-5.1p1-2.fc9.i386, but does work with the previously released version, openssh-5.0p1-3.fc9.i386, with no other changes (you can upgrade/downgrade/upgrade etc to reproduce).

Version-Release number of selected component (if applicable):
openssh-5.1p1-2.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1. put an 'echo' statement in .bashrc
2. ssh localhost date
3. see that the echo statement never happened
4. downgrade ssh to openssh-5.0p1-3.fc9.i386, repeat steps 1-3
  
Actual results:
.bashrc is not being run when a non-login, non-interactive remote shell is run, despite that it always has done so, and despite that bash says it will, and despite that there is code in bash (shell.c:970) to make it happen.


Expected results:
.bashrc should be run

Additional info:
Comment 1 Tomas Mraz 2008-10-22 13:00:51 EDT
The problem is the bash code is not currently compiled in.

*** This bug has been marked as a duplicate of bug 458839 ***

Note You need to log in before you can comment on or make changes to this bug.