Bug 46806 - Kernel 2.4.3-12 hangs when running X with ATI MACH 64 GTB card
Summary: Kernel 2.4.3-12 hangs when running X with ATI MACH 64 GTB card
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-30 20:11 UTC by Stephen Lewis
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2002-03-09 14:32:33 UTC


Attachments (Terms of Use)
Tarball of requested files plus good XFree startup (80.00 KB, text/plain)
2001-10-22 18:01 UTC, Stephen Lewis
no flags Details

Description Stephen Lewis 2001-06-30 20:11:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
Using both Red Hat 7.1 from CD and Red Hat 7.1 with all upgrades to
29/6/2001 from Red Hat network causes system crash when starting X session.

Starting a Gnome or KDE session causes the machine to hang within several
minutes of the start of the session (sometimes does not get past splash
screen).  Occasionally see green horizontal lines across top of screen when
crash occurs.
.



How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 7.1
2. Start an X session, either from graphical login or using startx.
3.
	

Actual Results:  System hangs totally

Expected Results:  X should work.

Additional info:

System is known good and has worked well using Red Hat 7.0.

Graphics card is reported as:

VGA compatible controller: ATI Technologies Inc 3D Rage II+ 215GTB [Mach64
GTB] (rev 154).

Problem fixed using Kernel 2.4.5.

Red Hat Network system ID 1000251138

Comment 1 Arjan van de Ven 2001-07-02 09:00:59 UTC
Mike: does this sound like anything related to kernel <-> XFree interactions ?

Comment 2 Mike A. Harris 2001-07-02 23:22:42 UTC
Hmm, the only kernel->X stuff would be DRM, or the AGP gart but this sounds
like a PCI card, and DRM is not supported on Mach64.

Could you boot into runlevel 3 after a crash, and attach the following files:
I would like to see the contents of /var/log/messages, /var/log/XFree86.0.log
as well as your /etc/X11/XF86Config* files.  Can you attach these using the
link below.

Could possibly something int10 related I suppose.  Does this machine have
more than one video card in it, including onboard adaptors (possibly disabled)?

Also, which 2.4.5 kernel has fixed this, one of ours, or a homebrew kernel?

Comment 3 Mike A. Harris 2001-07-02 23:25:01 UTC
The first line of above should read "that I can think of off the top of my
head" somewhere.  ;o)  I just also thought about USB, PS/2 issues.  If you're
using USB or PS2 devices, it is possible something has changed in the kernel
WRT that.

Comment 4 Stephen Lewis 2001-07-06 19:16:28 UTC
Requested files attached.

There's only a single graphics card & going by the rear panel of the PC there
doesn't appear to be an on-board graphics capability.

No USB devices attached, but mouse and keyboard are PS/2.

The kernel is a homebrew, with source downloaded from www.kernel.org as a
tarball (not patched).  If you point me to an RPM'd 2.4.5 kernel, I can give
that a try.

Comment 5 Stephen Lewis 2001-08-21 21:11:20 UTC
The problem is not fixed in kernel-2.4.7-2.i686.rpm downloaded from one of the 
UK rawhide mirrors.  I have tried downloading the 3.4.7 source and 
recompiling, but compiling the modules throws up errors.  Please supply your 
configuration options for the 2.4.5 kernel and I can try spinning that up.

Comment 6 Stephen Lewis 2001-10-21 21:26:16 UTC
Just downloaded kernel 2.4.9-6 in response to up2date notification.  The problem
is still there.  Homebrew 2.4.9 kernel works fine.

Comment 7 Mike A. Harris 2001-10-21 22:12:50 UTC
The files requested were not attached....

Comment 8 Stephen Lewis 2001-10-22 18:01:29 UTC
Created attachment 34581 [details]
Tarball of requested files plus good XFree startup

Comment 9 Stephen Lewis 2001-12-02 10:20:11 UTC
Have just downloaded 2.4.16 kernel source.  Exact same problem is there with SMP
turned off on latest homebrew kernel (SMP option was selected on older kernel to
overcome compilation error on ksyms.c).  Suspect timing problem on a buggy
motherbaord, but could still be S/W related.

Comment 10 Stephen Lewis 2002-03-09 14:32:29 UTC
Bug not present in Rawhide kernel-2.4.17-0.18.i686.rpm.

I believe the bug was present in 2.4.9-13, so the fix is somewhere between the
two build standards.  Recommend changing bug status to closed.  If you need any
more info, please ask.

Comment 11 Mike A. Harris 2002-03-11 01:21:04 UTC
Ok, closing bug as fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.