Bug 468065 - German umlauts are not correctly displayed in tty shells
German umlauts are not correctly displayed in tty shells
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: i18n (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: i18n Engineering List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 12:22 EDT by Roland Wolters
Modified: 2009-12-18 01:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:37:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot on console with umlauts (1.85 KB, image/png)
2008-10-22 23:50 EDT, Akira TAGOH
no flags Details
Screenshot on gedit with umlauts (22.61 KB, image/png)
2008-10-22 23:51 EDT, Akira TAGOH
no flags Details
testcase (15 bytes, text/plain)
2008-10-22 23:52 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Roland Wolters 2008-10-22 12:22:29 EDT
Description of problem:
The tty shells (the ones accessible via Ctrl+Alt+Fx) do not display my german umlauts correctly. Instead of the umlauts other charakters are displayed: the ä is displayed as a greek z, the Ä is displayed as a small 'ä', the ö is displayed as an old divide by sign (horizontal dot-dash-dot), the Ö is displayed as a û, the ü is an upper n, the Ü the sign for the British pound and the ß is displayed as an old German s (looks much like a f).

However, this is a display matter only: if I edit a file, enter some of these chars and open this file again under my KDE session all character look perfect.
Besides, other ouput like error messages or man pages are also only affected when viewed in the tty shells.

How reproducible:
Install Fedora 10 in German.

Steps to Reproduce:
1. Install Fedora 10 in German
2. Switch to a tty (Ctrl+Alt+F2)
3. Enter some German umlauts
  
Actual results:
The umlauts are not correctly displayed (but correctly saved!)

Expected results:
The umlauts should be displayed correctly.

Additional info:
My locale output:
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
Comment 1 Jens Petersen 2008-10-22 23:24:21 EDT
How does "man man" say look for you?  It looks ok for me here with rawhide.
Comment 2 Akira TAGOH 2008-10-22 23:50:50 EDT
Created attachment 321238 [details]
Screenshot on console with umlauts
Comment 3 Akira TAGOH 2008-10-22 23:51:31 EDT
Created attachment 321239 [details]
Screenshot on gedit with umlauts
Comment 4 Akira TAGOH 2008-10-22 23:52:48 EDT
Created attachment 321240 [details]
testcase

I've tried rawhide box installed yesterday, which should be 20081021 tree. and both results looks same to me.
Comment 5 Roland Wolters 2008-10-23 13:40:48 EDT
"man man" looks exactly like I described - but on ttys only!
That is important: the problem I described only affects the character display on ttys. The screenshots you made look much like they were taken under X - there I have no issues at all. On X, and therefore in gedit, Konsole or whatever I have no problems. But if I switch to a tty with Ctrl+Alt+F2 I do have problems.

Is there a way to create a png (!) screenshots of a tty? The only possibility I found was to do a 'setterm -dump 2', and that does indeed shows encoding problems - but the problematic chars are only replaced by a ? sign (black on white background). If it helps I can take a photo of the tty to better highlight the problem.
Comment 6 Akira TAGOH 2008-10-23 22:43:41 EDT
What I've tried rawhide is installed on vmware and took a screenshot with its feature. as I wrote as comment, first screenshot was exactly what I've taken on the console. to clarify, does it look good for you? then you may be missing something or already fixed in any packages recently. try yum upgrade and reboot. otherwise are you explicitly setting up SYSFONT envvar? see what does "echo $SYSFONT" say on the console.
Comment 7 Roland Wolters 2008-10-24 11:02:13 EDT
Yes, the first screenshot looks perfect for me. And I do have a system fully up2date, the problem is there since my first installation some weeks ago and has been there since then.

The sysfont variable is empty.
Comment 8 Jens Petersen 2008-10-27 01:29:28 EDT
(In reply to comment #7)
> The sysfont variable is empty.

That sounds like the problem.  I am assuming this is fixed in current rawhide now.
Comment 9 Roland Wolters 2008-10-27 12:46:54 EDT
Which package contains the variable, and what should it be set to?
Comment 10 Bug Zapper 2008-11-25 23:07:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Roland Wolters 2008-11-26 19:27:29 EST
I re-installed my system with a 64bit version of Fedora 10 final - and the problem still persists!
Comment 12 Jens Petersen 2008-11-26 23:02:35 EST
Could explain again exactly what you did?  It is a fresh install on a new filing system and no old partitions?
Comment 13 Jens Petersen 2008-11-26 23:10:38 EST
What is the content of /etc/sysconfig/i18n?

I just tried with a fresh install of F10 Live i386 and "LANG=de_DE.UTF-8 man man" displays fine for me.
Comment 14 Jens Petersen 2008-11-27 00:04:12 EST
I tried a German install too of F10 from Live and see

LANG="de_DE.UTF-8"
SYSFONT="latarcyrheb-sun16"

in /etc/sysconfig/i18n.  Again "man man" displays fine on console.
Comment 15 Bug Zapper 2009-11-18 07:39:15 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-12-18 01:37:37 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.