Bug 468070 - Activation Key Packages Not Getting Installed During Virt Kickstarts
Activation Key Packages Not Getting Installed During Virt Kickstarts
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 12:54 EDT by Devan Goodwin
Modified: 2008-10-30 23:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 14:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2008-10-22 12:54:51 EDT
Description of problem:

Packages listed to be installed as part of an activation key are not being installed when kickstarting a virtual guest.

Version-Release number of selected component (if applicable):

5.2.0

How reproducible:

Seems 100%.

Steps to Reproduce:
1. Create activation key with just a package to install. (tested with osad)
2. Create guest kickstart profile.
3. Associate kickstart profile with activation key.
4. Kickstart guest.
  
Actual results:

osad not installed.

Expected results:

osad should be installed. :)

Additional info:

Note that associating the exact same activation key with a *non* virt kickstart profile, osad installs fine. 

This leads me to believe the problem is in the registration code. We've already seen there are several very disjoint paths through this code depending on how you're registering, I suspect virt registrations are forking another direction where activation keys aren't getting processed properly.
Comment 1 Brandon Perkins 2008-10-30 11:34:07 EDT
Devan,

Two issues that I'd like your comments on:

1) In your "Steps to Reproduce", you are not specific on what method you are using to subscribe the system to the rhn-tools channel.  Can you please provide that exact step (kickstart vs activation key)

2) This test is only covering a package from a child channel.  Does this happen with base channel packages as well (a2ps, zsh, screen, etc).

Right now, there isn't enough information to accept this bug.
Comment 2 Devan Goodwin 2008-10-30 14:19:30 EDT
NOTABUG. I went back to verify and discovered I was doing something very stupid. Very stupid indeed.

osad gets installed if you actually apply it on the activation key instead of just calling your activation key "osad-key" and assuming that'll do the trick.

DOH
Comment 3 Brandon Perkins 2008-10-30 23:06:27 EDT
LOL

Note You need to log in before you can comment on or make changes to this bug.