Bug 468081 - Lat2-Terminus is not included in the installation image, although required for Romanian
Lat2-Terminus is not included in the installation image, although required fo...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 13:29 EDT by Alexandru Szasz
Modified: 2009-12-18 01:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:37:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen capture - Rawhide [Running] - Sun xVM VirtualBox.png (26.01 KB, image/png)
2008-10-22 14:54 EDT, Alexandru Szasz
no flags Details

  None (edit)
Description Alexandru Szasz 2008-10-22 13:29:57 EDT
Description of problem:

When installing Fedora in Romanian in text mode, the required font Lat2-Terminus is not loaded probably due to the fact that it's not present on the installation image.

Version-Release number of selected component (if applicable):
Rawhide

How reproducible:


Steps to Reproduce:
1. Start installation in text mode
2. Choose Romanian for the language of installation
3. Look at the squares that are shown instead of ș and ț
  
Actual results:

ș, ț, Ș, Ț are not displayed

Expected results:

ș, ț, Ș, Ț should be displayed correctly with the only font that has them, Lat2-Terminus

Additional info:
lang-table contains the following line that is correct:
Romanian        ro      Lat2-Terminus16 ro_RO.UTF-8     ro      Europe/Bucharest
Comment 1 Chris Lumens 2008-10-22 14:23:25 EDT
I'm not seeing this problem.  Are you correct in that this is happening in text mode on rawhide?  I checked graphical mode as well, just to be sure, and didn't see a problem there either.
Comment 2 Alexandru Szasz 2008-10-22 14:54:19 EDT
Created attachment 321192 [details]
Screen capture - Rawhide [Running] - Sun xVM VirtualBox.png

For the record, I used http://ftp.iasi.roedu.net/mirrors/fedora.redhat.com/linux/development/i386/os/images/boot.iso dated October 21.

I just tried it in a virtual machine and it seems to display the characters alright there but with some odd highlighting. On the laptop that I was installing, the intallation procedure started in vesa text mode and probably that's why the characters are displayed as squares.

Is this somehow related to the fact that șȘțȚ have codes over 256 ?
Comment 3 Alexandru Szasz 2008-10-22 14:56:09 EDT
(In reply to comment #2)
> 
> Is this somehow related to the fact that șȘțȚ have codes over 256 ?

Answering to myself: this couldn't be because ăîâ are displayed the same way and they have codes under 256.

I remember reading somehwere about how this font fiddled with the highlighting to get more space for characters ...
Comment 4 Răzvan Sandu 2008-10-24 08:44:52 EDT
Hello all,

At least in my installation of Fedora 10 rawhide these characters are not displayed correctly (they used to be in earlier versions of Fedora 9, but recently ceased to do so).

The exact Unicode codes (UTF-8) of these Romanian characters - the CORRECT ONES - are:

0218
0219
021A
021B

What we need is (at least) the following two packages included in ANY Romanian installation (and used by default):

terminus-font-console
terminus-font-x11

As far as I know, there are other font packages with correct Romanian characters in them, too (comma-below, not cedilla-below).


Regards,
Răzvan
Comment 5 Vitezslav Crhonek 2008-10-31 05:18:48 EDT
Hi,

So what is the request for kbd package? Lat2-Terminus16 font is part of kbd since 1.12-28, Romanian keymaps were fixed release or two before that.
Comment 6 Alexandru Szasz 2008-10-31 05:37:37 EDT
Did you see how the diacritics appear highlighted in the screen capture: https://bugzilla.redhat.com/attachment.cgi?id=321192 ? Is there nothing to be done do avoid that ?

On a laptop, those didn't appear at all. I'll try again with a more recent boot.iso and come back with a screenshot.
Comment 7 Răzvan Sandu 2008-11-01 00:18:52 EDT
Alex, looking at the screenshot you've mentioned in comment #6, it seems there are cedilla-below diacritics, not the correct comma-below ones. Am I right ?

Răzvan
Comment 8 Alexandru Szasz 2008-11-01 14:00:56 EDT
(In reply to comment #7)
> Alex, looking at the screenshot you've mentioned in comment #6, it seems there
> are cedilla-below diacritics, not the correct comma-below ones. Am I right ?
> 

That's my fault, I haven't switched the translations to the correct comma below. I'll try to fix that as soon as I can.
Comment 9 Brennan Ashton 2008-11-04 00:14:14 EST
This bug has been triaged
Comment 10 Bug Zapper 2008-11-25 23:07:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Răzvan Sandu 2009-01-29 01:45:54 EST
Hello,

Is this bug still present after latest updates of Fedora 10 (as of January 29th, 2009) ?

Regards,
Răzvan
Comment 12 Vitezslav Crhonek 2009-01-29 11:28:56 EST
I saw that diacritic appeared highlighted (as Alexandru mentioned in Comment #6) during install. I reproduced it on Fedora 10. But I believe that correct font with comma-bellow is used. So the problem is highlighting.

I didn't find a reason, except the statement in setfont manpage (Alexandru mentioned it in Comment #3):
Note: if a font has more than 256 glyphs, only 8 out of 16  colors  can
be  used  simultaneously. It can make console perception worse (loss of
intensity and even some colors).

But then I wonder why only some characters are highlighted?

If Anaconda really uses Lat2-Terminus16 (and it should use it, because that's what we fixed time ago) - I don't know any other way how to solve it (within kbd package), than try using different font - but AFAIK Lat2-Terminus16 is the only one font that meets your criteria, again, we worked on it time ago...
Comment 13 Bug Zapper 2009-11-18 03:37:28 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-12-18 01:37:47 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.