Bug 46809 - After upgrade 6.2 -> 7.0, RPM stopped working
Summary: After upgrade 6.2 -> 7.0, RPM stopped working
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-30 22:23 UTC by Greg
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-30 22:23:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg 2001-06-30 22:23:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-3 i586)

Description of problem:
RPM stopped working with the error "could not open packages index with
db1".  It was trying to open /var/lib/rpm/packages.rpm according to strace,
which is the old rh6.2 filename.  I solved it by chainging
/etc/rpm/macros.db1 to contain "%_dbapi         3" where it had contained
"%_dbapi         1".

Upgrade was using a custom-spun RH7.0 CDROM with all the updates as of
today (30-June-2001), as far as I know.  Some installer files may not have
been updated, but all RPMS were as well as some installer files.

How reproducible:
Didn't try


Actual Results:  I would have to restore from backup and attempt to
re-upgrade the server in order to reproduce the problem.  I have no
intention to do that to a production server.  I do know that the problem
comes back if I change the "3" back to "1" in /etc/rpm/macros.db1.  Every
time. :)

Additional info:

rpm version rpm-4.0.2-7x.i386.rpm

Comment 1 Brent Fox 2001-07-11 18:19:19 UTC
Since it was a custom spun 7.0, there's pretty much no chance for me to
reproduce the problem.


Note You need to log in before you can comment on or make changes to this bug.