Bug 468100 - "plymouth --hide-splash" clears screen when booting without "rhgb quiet"
"plymouth --hide-splash" clears screen when booting without "rhgb quiet"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-22 15:54 EDT by James Ralston
Modified: 2009-10-05 11:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 11:21:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2008-10-22 15:54:02 EDT
If I boot 2.6.27.3-30.rc1 without "rhgb quiet", just before this message appears:

Session finished...exiting logger

...something clears the screen and moves the cursor to (0,0).

2.6.27-13.0 doesn't do this; the "Session finished...exiting logger" line just scrolls the display.  (The initird init scripts are the same for both kernels, so there must be something in 2.6.27.3-30.rc1 that is clearing the screen.)

Scrolling the display is preferable to blanking the screen, as blanking the screen erases boot messages that may have value (see bug 461797).
Comment 1 Dave Jones 2008-10-22 16:00:17 EDT
The kernel shouldn't be doing anything here.  This is either initscripts, or possibly plymouth.
Comment 2 James Ralston 2008-10-22 19:16:48 EDT
After much "debugging via printk()" (so to speak), I've isolated what is clearing the screen, which is:

plymouth --hide-splash

(rc.sysinit's init_crypto() function runs "plymouth --hide-splash" before it runs cryptsetup.)

The bizarre thing is that plymouth only has this behavior with 2.6.27.3-30.rc1.  With 2.6.27-13.0, the screen isn't cleared.  This is 100% reproducible (by alternating booting with one kernel and then the other).

My guess is that plymouth's --hide-splash option has been trying (and failing) to clear the screen all along, but changes between 2.6.27-13.0 and 2.6.27.3-30.rc1 have "fixed" it so that plymouth actually succeeds now.

Re-filing against plymouth...
Comment 3 Ray Strode [halfline] 2008-10-22 21:22:04 EDT
okay, so what's going on is,

hide_splash_screen() for the details plugin has:

  for_each_window (plugin,
                   (ply_boot_splash_plugin_window_handler_t)
                   uninitialize_window, NULL, NULL);

uninitialize_window() has:

  ply_window_clear_screen (window);

We do this so that when plymouth quits the screen is blank so the crossfade to gdm fades from black instead of boot messages.

Sort of hard to fix that case and this one.  I guess crossfading from boot messages when you are using details isn't that bad, so I'll do that (especially since showing boot messages isn't the default)
Comment 4 Ray Strode [halfline] 2008-11-10 15:18:33 EST
This should be fixed in the latest builds.
Comment 5 James Ralston 2008-11-11 18:43:40 EST
Which builds?

(I'm still seeing this for plymouth-0.6.0-0.2008.11.10.5, which is the latest in rawhide ATM, but I'm not sure if there's anything else in the build queue...)
Comment 6 Ray Strode [halfline] 2008-11-11 23:15:27 EST
Make sure you rebuild your initrd (with /usr/libexec/plymouth/plymouth-update-initrd or /sbin/mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r) or installing a new kernel) after updating plymouth.

I think the build you mentioned should have the fix in it, but there have been several builds since then.
Comment 7 Bug Zapper 2008-11-25 23:08:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 James Ralston 2009-03-27 11:21:21 EDT
Everything has been working properly in F10 current; booting with "nomodeset" and without "rhgb quiet" loses no console output.
Comment 9 Orion Poplawski 2009-10-01 11:55:48 EDT
Is it really necessary to specify "nomodeset" without "rhgb" in order to see the boot messages?  This seems more trouble than should be needed.  It certainly made me have to poke around and find this bug report.
Comment 10 Ray Strode [halfline] 2009-10-05 11:01:48 EDT
No, shouldn't be neccessary.  If it's broken again, please file a new bug.

Note You need to log in before you can comment on or make changes to this bug.