Bug 468110 - Kwin Compositing (OpenGL) + picture frame plasmoid = crashy, too many windows
Kwin Compositing (OpenGL) + picture frame plasmoid = crashy, too many windows
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 17:01 EDT by Peter Gückel
Modified: 2009-01-09 16:00 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 16:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 179081 None None None Never

  None (edit)
Description Peter Gückel 2008-10-22 17:01:04 EDT
Description of problem:
When OpenGL effects are enabled, and, my guess is, but I could be wrong, that one is using the picture frame plasmoid (mine is set to show a new image every 10 seconds), the KDE desktop jams up after a while, say, about 1 hour or so. It becomes impossible to open windows, dolphin will not open directories, or other strange effects. I notice that the dashboard looks normal, except that where the picture frame plasmoid is supposed to be, there is only a small, black diamond shape. What I do then is open a virtual terminal with the intention of trying to change the desktop effects = true to false on line 6 of kwinrc, but I cannot even log in on a virtual terminal. I see the login prompt, and when I enter my login name, the prompt disappears and a line is repeated 2 or 3 times. I believe it reads something like: there are too many windows open. The computer is unresponsive and I have no choice but to alt-SysRq-reisuo.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.1.2-6.fc10.i386
kdeplasma-addons-4.1.2-2.fc10.i386
kdebase-runtime-4.1.2-5.fc10.i386
other?

How reproducible:
Enable Desktop Effects (and enable the Picture Frame Plasmoid and set it to about 10 minutes). Use the computer for an hour or so. All of a sudden, when one is not expecting anything, nothing works anymore and the diamond shape appears where the picture frame plasmoid is supposed to be. The virtual terminal displays a message about too many windows.

Steps to Reproduce:
1.See How reproducible.
2.
3.
  
Actual results:
Dolphin barely opens directories anymore, it becomes impossible to open a window, not even the menu to select a program to run, etc.

Expected results:
Kwin OpenGL Desktop Effects should work. Whether there is an interaction between the Picture Frame Plasmoid (which opens a lot of windows in succession over a period of time) is just a guess. I have not tried using the computer without the picture frame. Perhaps I should, just to see?

Additional info:
I am using the onboard Intel graphics using xorg-x11-drv-i810-2.5.0-1.fc10.i386, but the problem existed for many previous versions of this driver. I didn't report for a long time, because kde-4.0 was rather buggy, and then the mesa and X servers were not yet mature, and finally the Intel graphic driver was not yet ready, but as of yesterday, the last piece has finally tumbled into completion with the release of intel driver 2.5 (however, even that is not truly ratified until kernel-2.29 when the kernel patches to allow modesetting are in place). Nevertheless, perhaps now is a good time to begin to initiate a resolution to this problem.
Comment 1 Kevin Kofler 2008-10-22 17:10:35 EDT
KWin compositing is still rather buggy, it's disabled by default for a reason. 4.2 will have some code to test whether compositing is actually working and enable it by default if the test passes, so we can only hope that it will be more reliable in 4.2. There's not much we can do to fix this stuff within Fedora, it needs to be fixed upstream.
Comment 2 Rex Dieter 2008-10-22 18:13:19 EDT
In my experience, it's not kde that's buggy, but the compositing support in drivers.  I'd venture this to be a hw/driver bug.

What video hw/driver is in use here?
Comment 3 Rex Dieter 2008-10-22 18:17:12 EDT
Nevermind, I see intel in the comment now.

I can vouche that compositing was rock-solid for me (intel) with F-9/kde-4.1.  F-10 has regressed quite a bit in that regard.
Comment 4 Peter Gückel 2008-10-22 20:10:19 EDT
Ok. Just thought I'd bring it to attention. Yes, in F9, I used kde compositing without any problem. That's why I keep enabling it in F10, hoping that it will work. Then, I had this problem, was told it was DRI, then it was allegedly mesa, then it might have been the X server, and finally the intel driver, but as of yesterday, each of these components has finally given birth to a long-awaited update, so I thought...
Comment 5 Rex Dieter 2008-10-23 07:42:47 EDT
To be clear, is it kwin or X dying?  (From what I can tell the latter, which is what would likely point to a lower level issue)
Comment 6 Rex Dieter 2008-10-23 07:43:46 EDT
I've got the same hw, and previously could reproduce the issue too, I'll update fresh, to confirm.
Comment 7 Rex Dieter 2008-10-23 10:11:35 EDT
confirmed anti goodness, reassigning to i810 driver for some targetted love.

In the meantime, using XRender instead of OpenGL here seems to yield much better results for me.
Comment 8 Peter Gückel 2008-10-23 12:56:48 EDT
Well, I really could not say, but, since I have a display and desktop, and am able to close, but not open windows, not even the menu, and I still have use of the mouse pointer to close those windows, and the keyboard obviously works, as I am able to switch to a virtual terminal and can type my login name (but cannot log in) and I am able to type alt-SysRq-sub, so I don't think X has died. It seems to be a kwin issue.

I have removed the picture frame plasmoid since reporting this and, so far, have not experienced the problem again, but that is not a sufficiently long test for me to be convinced. I had just thought that it was opening a new 'window' or picture every 10 seconds, so perhaps they were not getting properly closed, hence that strange message about too many windows being open and the desktop freezing up.

Yes, back in January, with the initial kde-4.0 release, OpenGL was not yet available, so I used XRender, but it was very slow and I ended up disabling effects as a result. I haven't given it another try yet, but will do so, if my test of not using the picture frame plasmoid proves fruitless.
Comment 9 Rex Dieter 2008-10-23 13:20:16 EDT
OK, what I'm seeing is different than what are, I'll file separately.  

Reassigning back to kdebase-workspace.
Comment 10 Peter Gückel 2008-10-23 14:43:53 EDT
I don't know about my picture frame plasmoid theory. It happened again, and I have had it turned off sine yesteday.

I disabled OpenGL effects and am using XRender, now. Yuck! Is that ever slow and jumpy!
Comment 11 Rex Dieter 2008-10-23 14:47:47 EDT
interesting... for me it's opengl that gets "yuck... slow", xrender isn't great, but it's better... for me anyway. ymmv.
Comment 12 Bug Zapper 2008-11-25 23:08:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Joshua BA 2008-12-19 01:59:47 EST
I think I am encountering this bug. When I am using Desktop Effects in KDE with the OpenGL compositing type (XRender doesn't have this problem) the system will eventually tell me that too many files are open and refuse to open any file (including programs) or even allow logins through a console. Wen that happens, killing xorg frees up enough so that I can at least reboot properly.

I have been retrying to see if it happens agian after KDE and xorg updates but so far nothing has fixed it. If I let the system run (not even interacting with it) once it starts using up files it eventually uses up all of them.

/proc/sys/fs/file-nr shows the number of open files rapidly rise even up to 180000+ out of about 200000 (I try not to let it get higher than that when testing because if I hit the limit, I lose all my unsaved files).

I am running Fedora 10 on a Lenovo Thinkpad T61 with Intel graphics. I don't have an xorg.conf file and can't think of anything else relevant I should post. Tell me if you need anything. I would like my OpenGL compositing back :)
Comment 14 Peter Gückel 2008-12-29 19:32:55 EST
Update: I have reported this bug to kde:

http://bugs.kde.org/show_bug.cgi?id=179081
Comment 15 Steven M. Parrish 2009-01-09 16:00:24 EST
Thanks for reporting this upstream.  Going to close this as UPSTREAM and we will monitor for resolution

Note You need to log in before you can comment on or make changes to this bug.