Bug 468114 - core_collector line in /etc/kdump.conf fails due to errors from /sbin/mkdumprd
core_collector line in /etc/kdump.conf fails due to errors from /sbin/mkdumprd
Status: CLOSED DUPLICATE of bug 463878
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 17:55 EDT by Charlotte Richardson
Modified: 2009-09-06 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 10:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-10-22 17:55:28 EDT
Description of problem:
The /sbin/mkdumprd in RHEL5.3_Alpha can no longer parse the core_collector line in /etc/kdump.conf. The line looks like:
core_collector makedumpfile -d 31


Version-Release number of selected component (if applicable):
RHEL5.3_Alpha 2.6.18-118.el5

How reproducible:
Every time.


Steps to Reproduce:
1. Configure kdump.
2. Add the above line to /etc/kdump.conf.
3. Service kdump restart.
  
Actual results:
/sbin/mkdumprd: line 1716: test: too many arguments
/etc/kdump.conf: Need a location for core_collector


Expected results:
Should work (worked in RHEL5.2).


Additional info:
I have temporarily hacked /sbin/mkdumprd for our use to get around this by changing line 1752 to read:
kdmup_chk "test -n \"$config_val\"" "Need a location for $config_opt"

That is, I removed two extra pairs of back slashes around "$config_opt", making this line the same as it was in RHEL5.2. (You probably want to do this in a cleaner way...)
Comment 1 Neil Horman 2008-10-23 10:54:41 EDT

*** This bug has been marked as a duplicate of bug 463878 ***

Note You need to log in before you can comment on or make changes to this bug.