Bug 468134 - configured to suspend, but it shuts down - g-p-m or vbetool segfault?
configured to suspend, but it shuts down - g-p-m or vbetool segfault?
Status: CLOSED DUPLICATE of bug 414971
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 23:40 EDT by Mikel Ward
Modified: 2008-10-23 03:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 03:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2008-10-22 23:40:21 EDT
My laptop is configured to suspend when idle.

After going to lunch and coming back, the power light was flashing.  Keyboard and mouse presses did nothing.

I pressed the power key once, and it started a clean boot, suggesting it had either shutdown or crashed instead of suspending cleanly.

The last line in /var/log/messages from before the restart is
Oct 23 14:08:34 laptop kernel: vbetool[27346]: segfault at 244d ip 0806fa87 sp bffa6040 error 4 in vbetool[8047000+45000]
Comment 1 Mikel Ward 2008-10-22 23:43:04 EDT
/var/log/pm-suspend.log looks interesting.  Other files like /var/log/dmesg.old look too old to contain anything directly relevant.

Initial commandline parameters: --quirk-vbestate-restore --quirk-vbe-post
Thu Oct 23 14:08:31 EST 2008: Running hooks for suspend.
/usr/lib/pm-utils/sleep.d/00clear suspend: success.
/usr/lib/pm-utils/sleep.d/01grub suspend: not applicable.
/usr/lib/pm-utils/sleep.d/05led suspend: not applicable.
/usr/lib/pm-utils/sleep.d/10NetworkManager suspend: success.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend: not applicable.
/usr/lib/pm-utils/sleep.d/50modules suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55battery suspend: success.
/usr/lib/pm-utils/sleep.d/65alsa suspend: success.
/usr/lib/pm-utils/sleep.d/90clock suspend: success.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend: not applicable.
/usr/lib/pm-utils/sleep.d/95packagekit suspend: success.
/usr/lib/pm-utils/sleep.d/99hd-apm-restore.hook suspend: saving level 128 for device sda
success.
/usr/lib/pm-utils/sleep.d/99video suspend: Allocated buffer at 0x20000 (base is 0x0)
ES: 0x2000 EBX: 0x0000
/usr/lib/pm-utils/sleep.d/99video: line 46: 27346 Segmentation fault      vbetool "$@"
success.
Thu Oct 23 14:08:34 EST 2008: performing suspend
Comment 2 Mikel Ward 2008-10-23 02:24:34 EDT
It happened a second time.

In this case, I pressing a key on the inbuilt keyboard caused a couple of other lights to light up and the power light to go solid, suggesting it was trying to wake up, but the screen stayed blank.

That sounds a whole lot like bug 414971.  (I thought I was using the nvidia driver, but it turns out it recently got changed to nv.)
Comment 3 Mikel Ward 2008-10-23 03:00:40 EDT
Going to assume it's a dupe.

*** This bug has been marked as a duplicate of bug 414971 ***

Note You need to log in before you can comment on or make changes to this bug.