This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468135 - Kernel (r8169) Driver Bug
Kernel (r8169) Driver Bug
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 23:44 EDT by Peter Gückel
Modified: 2008-10-24 02:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 02:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2008-10-22 23:44:16 EDT
Description of problem:
The hwaddr is shown as 00:00:00:00:00:00, as seen by ifconfig eth0. As a result, I am unable to connect to the (wired) internet without manually setting the correct hwaddr and restarting the network.

Version-Release number of selected component (if applicable):
kernel-2.6.27.3-34.rc1.fc10.i686

How reproducible:
Boot using the aforementioned kernel

Steps to Reproduce:
1.Boot and log in
2.Observe NetworkManager fail to automatically connect to the wired network
3.
  
Actual results:
Upon login and startup of NetworkManager, there is no wired internet connection available and the hwaddr is erroneously shown as 00:00:00:00:00:00.

Expected results:
The correct hwaddr should be known to the system (it is correctly given in ifcfg-eth0 in the network-scripts and works with all previous kernels), and NetworkManager should automatically connect to the internet as it does for all previous kernels.

Additional info:
Alan Cox said that "if the hw addr is being reported as all zeroes that is almost certainly a kernel driver bug. Please file a bug against the kernel and report which network driver and hardware you are using." I am using Realtek RTL8111B/RTL8168B Gigabit Ethernet with the r8169 kernel module.
Comment 1 Michal Schmidt 2008-10-23 08:19:16 EDT
I'm seeing the same problem on my laptop with a RTL8101e.

I strongly suspect this change is to blame, because vanilla 2.6.27 works fine for me:
* Út říj 21 2008 Chuck Ebbert <cebbert@redhat.com> 2.6.27.3-32.rc1
- Update r8169 network driver to what is upstream for 2.6.28.


I have applied two commits from jgarzik's upstream-fixes branch to r8169.c and verified they fixed the problem for me:
cd926c7330ae76b620853533e68654a1ef0c2347 r8169: verbose mac address init 
e1564ec938b759268d6e67f24b5d6f429da4a5a9 r8169: checks against wrong mac addresse init 

Now I'm getting in dmesg:
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:08:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
r8169 0000:08:00.0: setting latency timer to 64
r8169 0000:08:00.0: no MSI. Back to INTx.
r8169 0000:08:00.0: Missing EEPROM signature: 00000000
eth0: RTL8101e at 0xffffc20000376000, 00:a0:d1:85:85:cd, XID 34200000 IRQ 17

... which is fine. Previously the MAC address was all zeros.

Please apply these two fixes to the F10 kernel or revert the r8169 update.

Michal
Comment 2 Peter Gückel 2008-10-23 12:44:13 EDT
The new kernel-2.6.27.3-39.fc10.i686 is also affected.
Comment 3 Michal Schmidt 2008-10-24 02:49:21 EDT
From the changelog:
* Thu Oct 23 2008 Jarod Wilson <jarod@redhat.com> 2.6.27.3-42
- Disable r8169 2.6.28 update patch, causes much bustification

I verified kernel-2.6.27.3-44.fc10 from Koji works fine again.

Note You need to log in before you can comment on or make changes to this bug.