Bug 468137 - Add username length restriction to FAQ
Add username length restriction to FAQ
Status: CLOSED DUPLICATE of bug 646236
Product: freeIPA
Classification: Community
Component: Documentation (Show other bugs)
unspecified
All Linux
medium Severity low
: v2 release
: ---
Assigned To: David O'Brien
Chandrasekar Kannan
: Documentation
Depends On:
Blocks: 489811 646217 646236
  Show dependency treegraph
 
Reported: 2008-10-23 00:49 EDT by David O'Brien
Modified: 2015-01-04 18:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 646236 (view as bug list)
Environment:
Last Closed: 2010-11-25 22:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2008-10-23 00:49:53 EDT
Description of problem:

Q:  quick question regarding the username length:
When we use "ipa-adduser" to create a new user, the username can not be longer than 8 chars, what is the particular reason for this? and How can i change it ? 

A: It is a setting in the policy. You can modify it either in the UI or on the command-line with:

ipa-defaultoptions --maxusername=INT 

The reason for it is that some non-Linux OSs have limitations on the length of the username so we went with the lowest-common denominator. 

Version-Release number of selected component (if applicable):
1.2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 David O'Brien 2010-11-25 22:24:42 EST

*** This bug has been marked as a duplicate of bug 646236 ***

Note You need to log in before you can comment on or make changes to this bug.