Bug 468150 - (iSCSI_rescan_pb) iSCSI luns deleted continue to appear in the UI and newly created does not come
iSCSI luns deleted continue to appear in the UI and newly created does not come
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Main
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 05:13 EDT by Julien Garet
Modified: 2014-07-06 15:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-13 13:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Garet 2008-10-23 05:13:15 EDT
Description of problem:
I deleted luns from my iSCSI target and created new ones. The problem is that in the UI, the former luns continue to be shown and the new ones does not appear.

Version-Release number of selected component (if applicable):
It's on version 0.95 (built from sources using instructions on the ovirt website)

How reproducible:
Everytime

Steps to Reproduce:
1. create 2 luns in an iSCSI target
2. add the target as storage host in the UI
3. delete the 2 luns and create 3 new ones of different size
4. refresh the volume list
  
Actual results:
the 2 first luns are still in the UI, the 3 new do not appear.

Expected results:
only see the 3 new ones.

Additional info:
- a refresh_pool message is well added to the taskomatic.log without any error messages.
- on the ovirt appliance accessing to the target in the console with iscsiadm gives the good result (3 new luns and not the 2 ancient ones)
- deleting the target on the filer, creating a new one with all the luns mapped to it and importing as storage pool in the UI works well
- filer is : openfiler 2.3, up to date, to manage iSCSI targets.
Comment 1 Hugh Brock 2009-05-22 11:08:36 EDT
This may now be fixed -- Ian can you verify?
Comment 2 Ian Main 2009-05-27 18:51:01 EDT
This is fixed with a combination of allowing the deletion of luns that don't really exist as well as the recent addition of using refresh() on pools.
Comment 3 Chris Lalancette 2011-07-13 13:57:27 EDT
Closing out this ancient bug.

Note You need to log in before you can comment on or make changes to this bug.