Bug 468157 - Empathy crashes on startup
Empathy crashes on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-23 06:00 EDT by David Nielsen
Modified: 2008-10-25 02:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: telepathy-gabble-0.7.12-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 02:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace and additional output (7.45 KB, text/plain)
2008-10-23 06:00 EDT, David Nielsen
no flags Details

  None (edit)
Description David Nielsen 2008-10-23 06:00:42 EDT
Created attachment 321261 [details]
backtrace and additional output

Description of problem:
Starting empathy it crashes after displaying the buddylist with the following output in the terminal.
** (empathy:29675): DEBUG: mission_control_get_presence_actual: MC not running.
** (empathy:29675): DEBUG: mission_control_get_presence_message_actual: MC not running.
** (empathy:29675): DEBUG: mission_control_get_online_connections: MC not running.
** (empathy:29675): DEBUG: mission_control_get_tpconnection: MC not running.
** (empathy:29675): DEBUG: mission_control_get_connection_status: MC not running.

** (empathy:29675): CRITICAL **: dbus_g_connection_get_connection: assertion `gconnection' failed
process 29675: arguments to dbus_connection_get_data() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 5758.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Multiple segmentation faults occurred; can't display error dialog


Version-Release number of selected component (if applicable):
empathy-2.24.1-1.fc10.x86_64
dbus-1.2.4-1.fc10.x86_64
telepathy-gabble-0.7.10-1.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start empathy
2. no really, it's that easy
  
Actual results:
segfault joy

Expected results:
im timewasting, unproductivity and the likes.

Additional info:
x86_64, da_DK.UTF-8
Comment 1 Peter Gordon 2008-10-24 14:45:24 EDT
Thanks for the bug report. Where does it crash if you strace it?
Comment 2 David Nielsen 2008-10-24 15:23:17 EDT
This is the last of the strace output just prior to the crash

read(3, 0x19fcaf4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN|POLLPRI}, {fd=27, events=POLLIN}, {fd=6, events=POLLIN}], 7, 0) = 0 (Timeout)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN|POLLPRI}, {fd=27, events=POLLIN}, {fd=6, events=POLLIN}], 7, 0) = 0 (Timeout)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN|POLLPRI}, {fd=27, events=POLLIN}, {fd=6, events=POLLIN}], 7, 0) = 0 (Timeout)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN|POLLPRI}, {fd=27, events=POLLIN}, {fd=6, events=POLLIN}], 7, 0) = 0 (Timeout)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN|POLLPRI}, {fd=27, events=POLLIN}, {fd=6, events=POLLIN}], 7, 0) = 0 (Timeout)
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN|POLLPRI}, {fd=27, events=POLLIN}, {fd=6, events=POLLIN}], 7, 0) = 0 (Timeout)
writev(6, [{"l\1\1\1\264\0\0\0\26\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/free"..., 144}, {"\257\0\0\0type='signal',sender=':1.1342"..., 180}], 2) = 324
write(2, "\n** (empathy:29627): CRITICAL **:"..., 99
** (empathy:29627): CRITICAL **: dbus_g_connection_get_connection: assertion `gconnection' failed
) = 99
write(2, "process 29627: "..., 15process 29627: )      = 15
write(2, "arguments to dbus_connection_get_"..., 199arguments to dbus_connection_get_data() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 5758.
This is normally a bug in some application using the D-Bus library.
) = 199
write(2, "  D-Bus not built with -rdynamic "..., 64  D-Bus not built with -rdynamic so unable to print a backtrace
) = 64
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(29627, 29627, SIGABRT)           = 0
--- SIGABRT (Aborted) @ 0 (0) ---
select(4, [3], [3], NULL, NULL)         = 1 (out [3])
writev(3, [{"\33\0\2\0\0\0\0\0"..., 8}], 1) = 8
read(3, 0x19fcaf4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL)         = 1 (out [3])
writev(3, [{" \0\2\0\0\0\0\0"..., 8}], 1) = 8
read(3, 0x19fcaf4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL)         = 1 (out [3])
writev(3, [{"%\0\1\0+\0\1\0"..., 8}], 1) = 8
select(4, [3], [], NULL, NULL)          = 1 (in [3])
read(3, "\1\2W\1\0\0\0\0\10\0 \5\0\0\0\0\360\370\325\1\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 32
read(3, 0x19fcaf4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
access("/usr/kerberos/bin/gdb", X_OK)   = -1 ENOENT (No such file or directory)
access("/usr/local/bin/gdb", X_OK)      = -1 ENOENT (No such file or directory)
access("/usr/bin/gdb", X_OK)            = 0
getuid()                                = 500
stat("/usr/bin/gdb", {st_mode=S_IFREG|0755, st_size=3692848, ...}) = 0
readlink("/proc/self/exe", "/usr/bin/empathy"..., 255) = 16
open("/usr/bin/empathy", O_RDONLY)      = 28
fcntl(28, F_GETFL)                      = 0x8000 (flags O_RDONLY|O_LARGEFILE)
pread(28, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\2\0>\0\1\0\0\0`\313@\0\0\0\0\0@"..., 64, 0) = 64
pread(28, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 1984, 176952) = 1984
pread(28, "\0.shstrtab\0.interp\0.note.ABI-tag\0"..., 289, 176656) = 289
pread(28, "empathy.debug\0\0\0~\315\320\25"..., 20, 174392) = 20
access("/usr/bin/empathy.debug", F_OK)  = -1 ENOENT (No such file or directory)
access("/usr/bin/.debug/empathy.debug", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/debug/usr/bin/empathy.debug", F_OK) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
write(2, "Multiple segmentation faults occu"..., 66Multiple segmentation faults occurred; can't display error dialog
) = 66
exit_group(1)                           = ?
Comment 3 Tom "spot" Callaway 2008-10-24 18:41:39 EDT
David, is this still happening? I can't reproduce this on rawhide.
Comment 4 David Nielsen 2008-10-24 19:00:47 EDT
yes, still happening
Comment 5 Brian Pepple 2008-10-24 19:09:21 EDT
David, are you using the latest tp-gabble-0.7.12 that was built yesterday?  I know that release had a couple of bug fixes in it that dealt with dbus issues.
Comment 6 David Nielsen 2008-10-25 02:33:26 EDT
telepathy-gabble-0.7.10-1.fc10.x86_64 ... hrmm this should have been automatically updated yet it appears not to, screw you yum.

Manually updating fixes this, thank you Brian

Note You need to log in before you can comment on or make changes to this bug.