Bug 46820 - rpm --rebuilddb segfaults after a user uses Kpackage
Summary: rpm --rebuilddb segfaults after a user uses Kpackage
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL: http://digilander.iol.it/melodymaker/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-01 13:21 UTC by Claudio Bandaloukas
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 11:09:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stderr output of rpm -vv --rebuilddb (21.74 KB, text/plain)
2001-07-01 13:35 UTC, Claudio Bandaloukas
no flags Details

Description Claudio Bandaloukas 2001-07-01 13:21:30 UTC
Description of Problem:
When a _user_ (not root) uses kpackage, sometimes a crash occurs. After that, the 
rpm database is unusable. 
db_verify /var/lib/rpm/Packages gives no output.
rpm -vv --rebuilddb segfaults with
<snip>
libstdc++-2.96-85
xmms-devel-1.2.5-2
SDL_mixer-1.1.0-2
xmms-more-vis-plugins-1.3.0-4rh
Segmentation fault

How Reproducible:
Not always

Steps to Reproduce:
Use kpackage until it crashes :-)

Actual Results:
rpm --rebuilddb segfaults
rpm -i segfaults
rpm -e sometimes segfaults

Expected Results:
rpm should update the database correctly ;-)

Additional Information:
I wonder if it is kpackage that does the damage. User programs shouldn't be able 
to do such damage.

Comment 1 Claudio Bandaloukas 2001-07-01 13:27:54 UTC
Oops, that was the output of rpm -qa
rpm -vv --rebuilddb output is in the attachment

Comment 2 Claudio Bandaloukas 2001-07-01 13:35:04 UTC
Created attachment 22328 [details]
stderr output of rpm -vv --rebuilddb

Comment 3 Need Real Name 2001-07-02 01:34:00 UTC
I have a similar, possibly related situation where rpm segfaults after -qa or --
rebuilddb or any other usage.  Gnorpm segfaults as soon as the root password is 
entered.

In my case I believe is is due to corruption of the db when StarOffice was 
uninstalled incorrectly.  "rpm -qa" shows a long list, then segfaults right 
after displaying the StarOffice package that no longer exists.  Attempts to use 
rpm to remove this package reply that the package does not exist.

I am a newbie, but if I can provide any information, please let me know.  This 
is a new RH7.1 install from a retail package (Delux Workstation).

Comment 4 Claudio Bandaloukas 2001-07-02 11:09:06 UTC
Ok, the problem seems to be a package called xmms-more-vis-plugins.

The package is a (bad) hack I made on an srpm from Mandrake ftp... 
(next time I'll learn ;-)

I use two methods in order to install packages.
One is rpm -Uvh (I tend to use it even when there was no previous release of a
package)
The other is through mc's menu (I just press return on the rpm and press enter
on "install" or "upgrade")
I am not sure which one I used to install this package.

However the src.rpm and the rpms I made with rpm --rebuild can be found at
http://digilander.iol.it/melodymaker/rpm/bad/xmms-more-vis-plugins-1.3.0-4rh.i686.rpm
http://digilander.iol.it/melodymaker/rpm/bad/xmms-more-vis-plugins-unsafe-1.3.0-4rh.i686.rpm
http://digilander.iol.it/melodymaker/rpm/bad/xmms-more-vis-plugins-1.3.0-4rh.src.rpm
(they were rebuilt using xmms-1.2.5 libraries)

Note: I haven't tried these, and cannot guarantee they will not trash your
computer if run ;-)


Comment 5 Jeff Johnson 2001-07-25 21:05:27 UTC
I believe this problem is resolved. Please reopen if I'm wrong.


Note You need to log in before you can comment on or make changes to this bug.