Bug 468251 - r8169 fails to read mac address in recent kernels
r8169 fails to read mac address in recent kernels
Status: CLOSED DUPLICATE of bug 468360
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 14:57 EDT by Trevor Davenport
Modified: 2008-10-24 11:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 11:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor Davenport 2008-10-23 14:57:52 EDT
Since kernel kernel-2.6.27.3-34.fc10.x86_64, r8169 driver fails to read the mac address when loaded.  This stops network from working.  Manually setting it fails.


kernel-2.6.27.3-30.fc10.x86_64 works without problems.  Loading r8169 with debug=16 reports:

r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
r8169 0000:03:00.0: setting latency timer to 64
r8169 0000:03:00.0: no MSI. Back to INTx.
eth0: RTL8168c/8111c at 0xffffc2000066e000, 00:00:00:00:00:00, XID 3c2000c0 IRQ 17
Comment 1 Adam Huffman 2008-10-24 05:41:10 EDT
Seeing the same problem here.
Comment 2 Yanko Kaneti 2008-10-24 08:10:43 EDT
This is fixed for me in 2.6.27.3-44, as the offending patch was disabled.
Comment 3 Dave Jones 2008-10-24 11:21:01 EDT

*** This bug has been marked as a duplicate of bug 468360 ***

Note You need to log in before you can comment on or make changes to this bug.