Bug 468266 - gdb is useless
gdb is useless
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 469681
  Show dependency treegraph
 
Reported: 2008-10-23 15:54 EDT by Jan Kratochvil
Modified: 2008-11-11 21:51 EST (History)
4 users (show)

See Also:
Fixed In Version: gdb-6.8-29.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 12:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-10-23 15:54:59 EDT
--- Additional comment from lpoetter@redhat.com on 2008-10-23 15:45:38 EDT ---

Indeed, "info threads" works after installing those debug symbols for glibc,

Segfaults and borkage isn't fixed though. I tried to track down bug 467651 a bit. No luck, gdb fails right-aways when opreport segfaults. A debugger that crashes when the debugged program crashes is pretty pointless, isn't it?

49 [lennart@lambda] ~$ gdb --args opreport -l /home/lennart/projects/pulseaudio/src/.libs/lt-pulseaudio 
GNU gdb Fedora (6.8-24.fc10)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(gdb) r
Starting program: /usr/bin/opreport -l /home/lennart/projects/pulseaudio/src/.libs/lt-pulseaudio
warning: [vdso] (tgid:30206 range:0x110000-0x111000) could not be found.
warning: [vdso] (tgid:32384 range:0x110000-0x111000) could not be found.
warning: [vdso] (tgid:32553 range:0x110000-0x111000) could not be found.
warning: [vdso] (tgid:5805 range:0x110000-0x111000) could not be found.
CPU: Core Solo / Duo, speed 1000 MHz (estimated)
Counted CPU_CLK_UNHALTED events (Unhalted clock cycles) with a unit mask of 0x00 (Unhalted core cycles) count 100000
../../gdb/buildsym.c:1281: internal-error: buildsym_init: Assertion `! pending_addrmap' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) y

../../gdb/buildsym.c:1281: internal-error: buildsym_init: Assertion `! pending_addrmap' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Create a core file of GDB? (y or n) y
Aborted
50 [lennart@lambda] ~$
Comment 1 Jan Kratochvil 2008-10-24 07:55:32 EDT
(In reply to Bug 468129 comment #4)
> Here you go:
> 
> http://0pointer.de/public/core.20500.gz
> 
> I sent gdb a SIGSEGV when the first question was asked to generate this dump.
> 
> gdb-6.8-24.fc10.i386

HTTP/1.1 403 Forbidden, fix it up, please.

Going to try it on i386, I was checking it on x86_64 before.
Comment 2 Lennart Poettering 2008-10-24 16:15:27 EDT
Sorry for that 403. Fixed.

oprofile apparently works fine on 64bit, it crashes only on x86.
Comment 3 Jan Kratochvil 2008-10-25 04:28:38 EDT
It is a regression against upstream due to the runtime evaluation of DWARF blocks (variable length array i oprofile), it should get fixed by backporting the updated patch:
http://people.redhat.com/jkratoch/vla/
Comment 4 Jan Kratochvil 2008-11-02 22:37:44 EST
Backported and committed to Rawhide CVS:
* Mon Nov  3 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-25
- Fix the variable-length-arrays support (BZ 468266, feature BZ 377541).

Built as:
http://koji.fedoraproject.org/koji/buildinfo?buildID=68325
http://koji.fedoraproject.org/packages/gdb/6.8/25.fc10/
Comment 5 Fedora Update System 2008-11-09 12:58:32 EST
gdb-6.8-23.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gdb-6.8-23.fc9
Comment 6 Jan Kratochvil 2008-11-10 12:47:53 EST
F10 GA: https://fedorahosted.org/rel-eng/ticket/1013
Comment 7 Fedora Update System 2008-11-11 21:51:32 EST
gdb-6.8-23.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.