Bug 468332 - Glitch-free audio deteriorates into a catastrophic series of glitches after about 10-20 minutes
Glitch-free audio deteriorates into a catastrophic series of glitches after a...
Status: CLOSED DUPLICATE of bug 462200
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 02:54 EDT by Peter Gückel
Modified: 2008-10-24 14:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 14:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2008-10-24 02:54:29 EDT
Description of problem:
1) I do not know whether it affects pure audio files (haven't listened in the last days), but when watching video files, the audio begins to sputter, cut out and finally die, sometimes resuming after a minute or so, only to decay anew. This affects flash-plugin, vlc, kplayer (mplayer-based), kaffeine (xine-based).
2) There is a similar problem, but I don't know if it is related, which I have only seen on flash-plugin, where the audio continues to play flawlessly, but the video stops, then after a minute or two, resumes in wacky fast-forward, until it catches up to the audio, only to play for a minute or so and again stop.
I do not know if these are related problems, as one affects audio, the other video, and the only program (so far) I have seen with both problems is flash-plugin (but never at the same time - either an audio problem or a video problem in the session, not both). When this happens, it only gets progressively worse, logging out and restarting X do not fix it: it is necessary to reboot the machine. Then, all is well for about 20-30 minutes, and it begins anew. I haven't tested a previous kernel yet.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-2.fc10.i386
kernel-2.6.27.3-39.fc10.i686
vlc-0.9.4-1.fc10.i386
kplayer-0.6.3-2.fc10.i386
kaffeine-0.8.7-2.fc10.i386

How reproducible:
Listen to/watch videos for a while, say on youtube or from the hard drive.

Steps to Reproduce:
1.Watch video for a duration of time, say 20-30 minutes, lose yourself and forget time.
2.Suddenly, the stuttering, glitches, cut-outs and eventual silence will occur. Stopping and restarting the video or quitting and restarting the application do not help.
3.Reboot and it is gone for a duration, when it begins anew.
  
Actual results:
The video plays, but the sound has cut out.

Expected results:
The sound should not cut out, stutter etc.

Additional info:
The problem labelled 2 above has been present since the release of flash-plugin 10, but did not affect flash-plugin 9. The problem labelled 1 above was noticed for the first time by me either Wed Oct 22 or Thurs Oct 23. I am not aware of having experienced it previously (but I wasn't watching a lot of videos until just these last couple of days).
For the second problem (the video that stops and restarts in flash-player), which might be a separate problem, or just another facet of the whole problem, there was some discussion on fedora-devel-list, I think, that suggested that this affects only dual- or multi-core processors.
Comment 1 Peter Gückel 2008-10-24 14:03:49 EDT
May be the same as Bug 462200, although this relates to i386, not _64.
Comment 2 Lennart Poettering 2008-10-24 14:15:50 EDT
Looks like bug 462200. Make sure to update to -4 at least.

*** This bug has been marked as a duplicate of bug 462200 ***

Note You need to log in before you can comment on or make changes to this bug.