Bug 468333 - error
error
Status: CLOSED DUPLICATE of bug 468355
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 03:15 EDT by leon
Modified: 2008-10-24 23:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 23:46:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leon 2008-10-24 03:15:27 EDT
Component: system-config-network
Version: 1.5.10
Summary: TB24531662 NCBackendHal.py:103:getDevices:TypeError: not enough arguments for format string

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 275, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 300, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 312, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 759, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 603, in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 483, in updateFromSystem
    self.updateFromHal(hdellist)
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 448, in updateFromHal
    cards = hal.probeCards()
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 124, in probeCards
    card = self.getDevices(udi)
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 103, in getDevices
    hw.Description = "%s %s" % self.getVendor(udi)
TypeError: not enough arguments for format string

Local variables in innermost frame:
category: net
obj: <ProxyObject wrapping <dbus._dbus.SystemBus (system) at 0xa50f98c> :1.0 /org/freedesktop/Hal/devices/net_3a_79_4b_67_e6_7e at 0xa5121ac>
name: pan0
arp_proto_hw_id: 1
hwf: {'Wireless': {0: <class netconfpkg.plugins.NCHWWireless.HwWireless at 0xa0b832c>}, 'Ethernet': {0: <class netconfpkg.plugins.NCHWEthernet.HwEthernet at 0xa078e6c>}, 'Modem': {0: <class netconfpkg.plugins.NCHWModem.HwModem at 0xa0b802c>}, 'ISDN': {0: <class netconfpkg.plugins.NCHWIsdn.HwIsdn at 0xa078f2c>}, 'Token Ring': {0: <class netconfpkg.plugins.NCHWTokenring.HwTokenring at 0xa0b823c>}}
self: <netconfpkg.NCBackendHal.NCBackendHal instance at 0xa51214c>
hw: Hardware.Status=nieaktywne
Hardware.Name=pan0
Hardware.Type=Ethernet

hwc: netconfpkg.plugins.NCHWEthernet.HwEthernet
htype: Ethernet
udi: /org/freedesktop/Hal/devices/net_3a_79_4b_67_e6_7e
getHardwareFactory: <function getHardwareFactory at 0xa07cf7c>
Comment 1 Matthias Clasen 2008-10-24 23:46:35 EDT

*** This bug has been marked as a duplicate of bug 468355 ***

Note You need to log in before you can comment on or make changes to this bug.