Bug 468365 - satellite webui does not see monitoring scout public key
satellite webui does not see monitoring scout public key
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
:
Depends On:
Blocks: 463877 486216
  Show dependency treegraph
 
Reported: 2008-10-24 08:18 EDT by Milan Zázrivec
Modified: 2009-09-10 14:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (54.99 KB, image/png)
2008-10-24 08:24 EDT, Milan Zázrivec
no flags Details

  None (edit)
Description Milan Zázrivec 2008-10-24 08:18:39 EDT
Description of problem:
* Satellite-5.3.0-RHEL4-re20081022.0 / s390x
* Activated monitoring, enabled monitoring scout

Navigate to:
Monitoring -> Scout Config Push -> Arbitrary scout in list

you'll get a mesage telling: "No RHNMD Public Key found for scout"
(see attachment)

Seemingly spacewalk-web does not know home directory for nocpulse
user was moved to /var/lib/nocpulse/

Version-Release number of selected component (if applicable):
spacewalk-web-0.3.1-2
Comment 1 Milan Zázrivec 2008-10-24 08:24:27 EDT
Created attachment 321401 [details]
screenshot
Comment 2 Milan Zázrivec 2008-10-24 09:12:27 EDT
> select value from rhn_config_parameter where group_name = 'netsaint'
and name = 'satKeyFile';

VALUE
--------------------------------------------------------------------------------
/opt/home/nocpulse/.ssh/nocpulse-identity.pub

^^ that's from satellite-schema-5.3.0-1.el4

This seems to be changed in upstream spacewalk-schema-0.3.4-1:
$ grep '.ssh' rhn_config_parameter_data.sql 
insert into rhn_config_parameter(group_name, name, value, security_type, 
last_update_user, last_update_date) values ( 'netsaint', 'satKeyFile',
'/var/lib/nocpulse/.ssh/nocpulse-identity.pub', 'ALL', 'system',sysdate);

I'm not sure whether this affects the problem at all ...
Comment 3 Milan Zázrivec 2008-10-25 14:07:55 EDT
Problem is still present with satellite-schema-5.3.0-2.el5 (based on
upstream spacewalk-schema-0.3.4-1).
Comment 4 Clifford Perry 2008-10-25 14:27:32 EDT
Pretty sure that the scripts used to generate the entries is messed up somehow.
Comment 5 Miroslav Suchý 2008-10-29 09:02:35 EDT
Problem is that this query:
SQL> select PUBLIC_KEY from rhn_sat_cluster;

PUBLIC_KEY
--------------------------------------------------------------------------------


should return the key. So somebody do not populate the db correctly.
Comment 6 Miroslav Suchý 2008-10-29 18:00:18 EDT
Well I think that my fix in BZ 468537, can be fix for this bug as well. Have to try it.
Comment 7 Miroslav Suchý 2009-01-30 05:42:27 EST
I can see it now.
Comment 8 Miroslav Suchý 2009-02-04 08:51:07 EST
Mass moving ON_QA
Comment 10 wes hayutin 2009-06-15 16:03:22 EDT
this is back in 6/12.1 build selinux enforcing
fails_qa
Comment 11 wes hayutin 2009-06-15 16:08:30 EDT
restarting MonitoringScout by itself seems to work around the issue, but the default install has the problem.

1. install sat w/ selinux enforcing
2. enable monitoring, restart satellte w/ /usr/sbin/rhn-satellite restart..
Comment 12 Miroslav Suchý 2009-06-15 18:02:11 EDT
Do you have some AVC messages in audit.log?
Comment 13 Miroslav Suchý 2009-06-16 09:01:13 EDT
I tried as best, but could not reproduce it. Can you provide more data.
Comment 14 wes hayutin 2009-06-16 09:17:01 EDT
k.. will put back on qa so we double check it next build
Comment 15 wes hayutin 2009-06-23 13:27:17 EDT
verified 6/19
Comment 16 Milan Zázrivec 2009-09-02 10:17:41 EDT
Verified in stage -> RELEASE_PENDING
Comment 17 Brandon Perkins 2009-09-10 14:14:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.