This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 468405 - smolt statistics web page seems to be frozen
smolt statistics web page seems to be frozen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
http://smolts.org/static/stats/stats....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 12:01 EDT by Răzvan Sandu
Modified: 2009-01-05 01:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 01:22:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-10-24 12:01:16 EDT
Description of problem:

Maybe it's not the right place to report this, but the smolt statistics at 

http://smolts.org/static/stats/stats.html

seems to be "frozen" with data from August 21, 2008.

Best regards,
Răzvan
Comment 1 Mike McGrath 2008-10-24 23:06:13 EDT
I know what this is and did a quick fix to test it but I won't be able to implement a complete fix until after the change freeze is lifted.  Should be on the 5th.
Comment 2 Răzvan Sandu 2008-10-31 23:32:23 EDT
Hello,


As far as I see, the statistics page "upgraded" to October 24th (probably by Mike, manually), but is still freezed.

Another fact I've noticed is that, despite the fact I run smolt on ~100 CentOS machines, all with smolt in automatic, no data about CentOS (or other Linux flavour) shows up in the statistcs. I assume other people do the same (maybe on other distros, like RHEL, Ubuntu...). Is that a design decision in smolt - to limit it to counting *Fedora* machines ?


Regards,
Răzvan
Comment 3 Mike McGrath 2008-11-01 11:10:21 EDT
We're still in our infrastructure change freeze so I haven't put this change through, there's a window between this pre-release freeze and the final freeze that I should be able to complete this in.  Its really just a matter of re-adding a cron job that got lost at some point.

As far as machines not showing up that's mostly because we have a limit in the actual query.  I'll take a look at getting that upped to the top 15 OS's.  I'll change that to top 30 and do another manual run of the stats cache update.
Comment 4 Răzvan Sandu 2008-11-19 03:56:23 EST
Hello,


For a short time (a few days), the smolt page showed up a more diverse statistic, including CentOS and RHEL. Now it went back to showing only Fedora machines.

It's also hard to believe that 98,1% of the machines run in default runlevel 5 (this is *very* uncommon on servers and Linux routers...).  ;-)


Regards,
Răzvan
Comment 5 Mike McGrath 2008-11-19 09:17:33 EST
I missed the window between the pre-release freeze and the final freeze.  I've made these changes to smolt upstream and hope to deploy it shortly after F10 final ships.  It will also finally have device and profile browsing / searching.  This will also fix the currently frozen stats page.

As far as runlevel 5 goes this is a known issue.  Those running in a default mode actually get prompted to enable smolt, if you kickstart your host there's no prompt and people have to enable smolt manually.  This causes an unfair trend towards runlevel 5.  There's actually been a lot of discussion about how to fix that but nothing concrete to actually implement.
Comment 6 Bug Zapper 2008-11-25 23:11:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Răzvan Sandu 2008-11-26 01:40:07 EST
Hello,

Regarding comment #5 :

Now that Fedora 10 was officially launched, please push the latest variant of smolt in the repository, to "unlock" the stats page and get the leastest information about hardware.


Thanks a lot,
Răzvan
Comment 8 Răzvan Sandu 2009-01-05 01:22:09 EST
This seems to be solved, I'll close it.

Many thanks,
Răzvan

Note You need to log in before you can comment on or make changes to this bug.