Bug 468408 - pyusb-aware code too fragile
pyusb-aware code too fragile
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On: 468692
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 12:20 EDT by Tim Waugh
Modified: 2009-02-25 11:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.19-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 11:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-10-24 12:20:12 EDT
Plugging in a printer fails to add a new queue.  Worked in 0.6.17-2.fc10.
Comment 1 Tim Waugh 2008-10-24 12:28:14 EDT
Should be fixed in 0.6.17-4.fc10.
Comment 2 Tim Waugh 2008-10-24 12:34:43 EDT
Fix confirmed.
Comment 3 Tim Waugh 2008-10-27 09:18:40 EDT
Re-opening: testing with a different make of printer causes the same problem again.

The reason is that the pyusb-using code fails, and if that happens the entire operation is aborted.
Comment 4 Tim Waugh 2008-10-27 09:56:34 EDT
Ah, a more serious reason is that hal is no longer giving us 'printer' devices...
Comment 5 Tim Waugh 2008-10-28 04:24:10 EDT
Removing F10Blocker for this bug, as the hal bug (bug #468692) was the blocker.
Comment 6 Tim Waugh 2008-10-28 07:29:42 EDT
Fix committed upstream; awaiting verification.
Comment 7 Tim Waugh 2008-11-03 05:13:28 EST
Verified.

Should add pyusb as a requirement when rebuilding package.
Comment 8 Bug Zapper 2008-11-25 23:11:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2009-01-14 22:03:04 EST
hal-cups-utils-0.6.19-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hal-cups-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0487
Comment 10 Fedora Update System 2009-02-25 11:25:29 EST
hal-cups-utils-0.6.19-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.