Bug 468417 - Compact Flash is slow as ATA/IDE via PCMCIA, fast as USB2.0
Compact Flash is slow as ATA/IDE via PCMCIA, fast as USB2.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 13:01 EDT by John Reiser
Modified: 2008-10-28 14:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 14:28:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages from session (45.86 KB, text/plain)
2008-10-24 13:01 EDT, John Reiser
no flags Details
lspci; lspci -n; lspci -v with USB2.0 adapter (6.61 KB, text/plain)
2008-10-24 13:04 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-10-24 13:01:09 EDT
Created attachment 321437 [details]
/var/log/messages from session

Description of problem: A Compact Flash card [storage device] that is used directly as an ATA/IDE device (via PC Card Adapter [PCMCIA]) achieves only 1.5MB/s transfer.  The same Compact Flash card in a USB2.0 card reader, attached to a USB2.0 PC Card adapter [same PCMCIA slot] achieves 20 MB/s transfer.  Also, when used directly as an ATA/IDE device, the clock loses many ticks.  Over 3.5 minutes, the clock can lose up to 3.2 minutes (90% loss of ticks, as reported by /bin/date versus an external stop watch.)


Version-Release number of selected component (if applicable):
kernel-2.6.26.6-79.fc9.i686

How reproducible: always


Steps to Reproduce:
1. echo 1 >/proc/sys/vm/drop_caches
2. date; time dd if=320MB bs=4k of=/dev/null; date
3.
  
Actual results: When Compact Flash card is connected as ATA/IDE device: 320MB transfered in 3.5 minutes wall clock (1.5MB/s), yet 'date' reports varying real times ranging from 18 seconds to 3 minutes.  When same Compact Flash card is connected through USB2.0 reader and USB2.0 PC Card adapter: 320MB transfered in 16 seconds (19.9MB/s) and 'date' agrees.


Expected results: Same fast speed of 20MB/s from both ATA/IDE and USB2.0 usage.


Additional info: Compact Flash card is labeled "133X" where 1X is 150KB/s.

Complete /var/log/messages will be attached.  Note disagreement over PIO6 [line 4 of excerpt below] versus PIO0 [lines 6 and 7]:
-----
Oct 24 07:47:49 farmer kernel: pcmcia: registering new device pcmcia0.0
Oct 24 07:47:49 farmer kernel: scsi2 : pata_pcmcia
Oct 24 07:47:49 farmer kernel: ata3: PATA max PIO0 cmd 0x100 ctl 0x10e irq 3
Oct 24 07:47:49 farmer kernel: ata3.00: CFA: ELITE PRO CF CARD 8GB, Ver2.19K, max PIO6
Oct 24 07:47:49 farmer kernel: ata3.00: 15761088 sectors, multi 0: LBA
Oct 24 07:47:49 farmer kernel: ata3.00: configured for PIO0
Oct 24 07:47:49 farmer kernel: ata3.00: configured for PIO0
Oct 24 07:47:49 farmer kernel: ata3: EH complete
Oct 24 07:47:49 farmer kernel: isa bounce pool size: 16 pages
Oct 24 07:47:49 farmer kernel: scsi 2:0:0:0: Direct-Access     ATA      ELITE PRO CF CAR Ver2 PQ: 0 ANSI: 5
-----
Comment 1 John Reiser 2008-10-24 13:04:05 EDT
Created attachment 321438 [details]
lspci; lspci -n; lspci -v  with USB2.0 adapter
Comment 2 Alan Cox 2008-10-28 14:28:18 EDT
Not really a bug

The PCMCIA interface is only capable of PIO0 at the bus level. The time slipping looks like a very slow card transfer. Thats a known bug with its own upstream bug # so I'll close this one

Note You need to log in before you can comment on or make changes to this bug.