This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 468422 - (CVE-2008-6170, CVE-2008-6171, CVE-2008-6176) CVE-2008-6170 CVE-2008-6171 CVE-2008-6176 drupal: multiple security issues in < 6.6,5.12 (SA-2008-067)
CVE-2008-6170 CVE-2008-6171 CVE-2008-6176 drupal: multiple security issues in...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 13:43 EDT by Jan Lieskovsky
Modified: 2009-03-10 13:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 13:34:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2008-10-24 13:43:25 EDT
Drupal upstream has released Drupal 5.12/6.6 to resolve two security issues.

References:
http://drupal.org/node/324824
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=503222
Comment 1 Tomas Hoger 2008-10-24 14:36:13 EDT
Summary of the issues:

- local file inclusion (config file for IP-based virtual hosts) (5.x, 6.x)
- XSS in the title of book pages (6.x only)
Comment 2 Fedora Update System 2008-10-24 19:52:16 EDT
drupal-5.12-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2008-10-30 08:49:58 EDT
drupal-6.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Jan Lieskovsky 2009-02-21 06:50:37 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-6176 to
the following vulnerability:

bootstrap.inc in Drupal 5.x before 5.12 and 6.x before 6.6, when the
server is configured for "IP-based virtual hosts," allows remote
attackers to include and execute arbitrary local files via unspecified
vectors.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-6176
http://drupal.org/node/324824
http://www.securityfocus.com/bid/31900
Comment 5 Jan Lieskovsky 2009-02-21 07:27:31 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-6170 to
the following vulnerability:

Cross-site scripting (XSS) vulnerability in Drupal 5.x before 5.12 and
6.x before 6.6, allows remote authenticated users with create book
content or edit node book hierarchy permissions to inject arbitrary
web script or HTML via the book page title.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-6170
http://drupal.org/node/324824
http://www.securityfocus.com/bid/31882
http://secunia.com/advisories/32297
Comment 6 Jan Lieskovsky 2009-02-21 07:39:08 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-6171 to
the following vulnerability:

Drupal 5.x before 5.12 and 6.x before 6.6, when the server is
configured for "IP-based virtual hosts," allows remote attackers to
include and execute arbitrary files via unspecified vectors.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-6171
http://drupal.org/node/324824
http://www.securityfocus.com/bid/31882
Comment 7 Jon Ciesla 2009-03-10 13:04:21 EDT
Why is this still open?
Comment 8 Vincent Danen 2009-03-10 13:34:43 EDT
Very good question.  At first I thought it was because EPEL had a vulnerable version, but it looks like it has 5.15 which is not vulnerable.

Closing.

Note You need to log in before you can comment on or make changes to this bug.